Jump to content
Sign in to follow this  
cybersphere

Menu unadjustable once upgraded to PageLines 2.0, also Feature on 'Blog Page' misbehaving.

Recommended Posts

cybersphere

Hi, So I braved the new world of PageLines 2.0. I love the 'page level' adjustments (rather then 'site level'). I have only just went through the entire PagelinesPro menu options and I am only just getting the feel for it. Anyway, stuck on 2 things (for now). Issue 1: Menu Once upgraded to 2.0, I can not adjust my MENU. Originally in 1.5.3, my menu consisted of: Home (custom) - link back to home page Services (page) Products (page) About Us (page) etc., Once upgraded to 2.0RC4, my 'Home' link disappeared from the menu. I tried deleting it from the WP-Admin > Menus but that did not make it come back. I have even tried deleting the whole menu (I only have one menu) and created from scratch but no go. When I say 'o go', I mean the menu does NOT change from the state it was in when I upgraded from 1.5.3. I even deleted my menu completely and it is still how it was, when I upgraded from 1.5.3. Do I adjust menu from somewhere else, other then WP-Admin > Menus? I even cleared cache in Safari and tried using another device but I still see the 1.5.3 menu! Issue 2: Features Two things I have learned about Feature in 2.0 is that you can adjust the height (2.0 default is no longer 330px so you will see some black bar under the image). You change this from WP-Admin > Special > (Choose appropriate page like 'Blog Page') > [Features] and adjust the height, feature set, transition duration, transition style, etc., This only removed black bar from my front page. As 2.0 has 'Page Level' control over Features, open the appropriate Page (eg. Products) and you will see these adjustments for other pages. Also, you have to set both 'transition speed' and 'feature viewing time' for auto transition slides to work. I only had the 'transition speed' set (like in the 1.5.3) but it did not make it transition. Now that I have shared that... to my question. I can choose different Feature sets for SOME of the individual pages BUT when I tried to set a specific feature for my front page (Pagelines > Special > Blog Page > [Features] > 'Select Feature Set'), it will not let me change the feature set. No matter what I choose (ie. set 1 or set 2 or leave it blank), Pagelines 2.0 behave as if I have selected no feature set and shows me ALL the feature slides. You help would be appreciated. Thanks! Paul PS. Moderators - would it be a good idea to create a separate forum CATEGORY for Pagelines 2.0 questions so it does not get mixed up with Pagelines 1.5.x? I feel that answers will be very different between these versions and it might be easier to search for past Q&As.

Share this post


Link to post
Share on other sites
cybersphere
Issue 3: WIDGETS I came across another odd one so... I had a Text box inside the 'Full Width Sidebar' widget in Pagelines 1.5.3. Once I have upgraded to 2.0, that same Text box (still containing my text) moved to 'MoreFoot Left' widget. It was just a matter of dragging it out and moving it to the Full Width Sidebar widget but I thought it might interest Pagelines developer to who this.

Share this post


Link to post
Share on other sites
catrina
Thanks for the note. I'll mark it for developer attention. Btw, the separate category for 2.0-related issues is here: http://www.pagelines.com/forum/categories/framework

Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
cybersphere
So... any suggestions for my menu issue (issue 1) and feature issue (issue 2)? I am assuming not too many people are experiencing the menu issue (may be I am the only one!?). Just looking to see what sort of turn around time I am looking at. I really don't want to create the website from scratch using 2.0. Paul PS. I'm just going to 'reject' your post for post status purpose. PPS. Thanks for the info on "Pagelines Framework" category. Due to the name change, it might be a good idea to have a 'sticky' post at the top of 'PlatformPro' category instructing people to post in "Pagelines Framework" category all matters 'PlatFormPro 2.0 matters'. Just a suggestion.

Share this post


Link to post
Share on other sites
cbrown509
Overall, Very happy with the upgrade. Nice work! I would also like to know how to adjust the height of the features. Thanks, Chris

Share this post


Link to post
Share on other sites
cybersphere
@ cbrown509 - First 2 paragraphs under my ordinal post, heading "Issue 2: Features" shows how I adjusted height.

Share this post


Link to post
Share on other sites
cybersphere
I have deleted Features and re-created one 'slide' at a time but the front page (based on Blog Page template) ignores 'Feature set' settings and continue to display ALL slides. Bummer! :((

Share this post


Link to post
Share on other sites
Danny
@cybersphere, On the WP Dashboard --> Menus, on the left hand side did you select the "Theme Location", it should be set to "Primary Website Navigation", check this and click save on Theme locations. I'll look into the Feature set issue too, ill post here when I find anything. @cbrown509 - To adjust the height of a feature enter the number and nothing more, so for example, lets say you want a feature to be 200px in height, you would add 200 and nothing else, adding 200px will revert it back to it's default from my testing. Try this please and let me know if that did the trick.

Please search our forums, before posting!

Share this post


Link to post
Share on other sites
cybersphere
@Danny - Thank you! WP Dashboard > Menu - Nothing was selected in 'Primary Website Nav'. Doh!! I wonder if you can also help me with sub-set of this solution. It appears the font size is larger for menu in Pageline Platform, compared with Platform 1.5.3... my menu does not fit and it goes to 2nd row. (a) Can you please tell me what the Custom CSS code is to resize 'menu' text? (b) Also, is there a CSS code to reduce the width of the 'Search box'? Ideally, I would like to keep the search box and just reduce the font size a little but I may have to play with both settings to achieve a good balance. Also, thanks re: Feature Set issue.

Share this post


Link to post
Share on other sites
kastelic
a. [code].main_nav li a {font-size: 12px;}[/code] b. [code] .searchform { width: 150px; } .searchform .searchfield { width:110px !important; } [/code]

Share this post


Link to post
Share on other sites
cybersphere
@kastelic - thanks again for your support. Solution a & b both worked BUT it appears there is a invisible separation between the menubar and the search box. No matter how call I make the search box (and therefore it is not squashing the menu bar space), the menu can not span closer to the search box. It seem to 'hit' an invisible 'wall' and the last menu items appears in the 2nd row. Please see: http://justitia.com.au/web/ for example.

Share this post


Link to post
Share on other sites
erik@grancanaria360.com
I had the same issue with the feature weird behavior. I went through EVERY setting and parameter and could??t make it work. Was driving me nuts. Strange enough, as funny as the main/blog page feature was acting (showing EVERY feature set regardless of the settings), as soon as I set a feature for an individual post, both the individual post AND the main/blog page features started behaving as expected... Go figure..

Share this post


Link to post
Share on other sites
cybersphere
Hi Erik, You had better luck then I did. I have set both the home/blog page feature (feature set 1) and individual page feature (feature set 2) and home/blog page continue to display all of the feature slides, while individual pages are working as expected and only displaying assigned feature set. It might be still little too early to call it a 'bug' (forgive me Pageline staff) but it just might be...

Share this post


Link to post
Share on other sites
Rob
Hi, Would you mind trying this in Dashboard > PageLines > Custom Code in the CSS Rules area? [code].searchform .searchfield { height: 13px; padding: 7px 15px 5px 7px; width: 80px; }[/code] If you have any success with it, but want to adjust it, change the 15px (the padding of the search field to the left) You may also wish to adjust 80px to whatever size you prefer. I noticed you changed your search field to 50px which is somewhat small, but without effect on the menu. I cut 30px to 15px for the left padding. It could work with less. Let us know how this goes. Thanks.

Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
cybersphere
Hi Rangelone, I have tried your code and it does make adjustments to the search field but as you can see on my site, it is now 'left justified' against that invisible wall that is still preventing the menu from spreading across. The code I used was: .searchform .searchfield { height: 13px; padding: 7px 5px 5px 7px; width: 50px; } My site is: http://justitia.com.au/web/ Thanks for taking a look. Maybe the padding has to be adjusted from the menu side?

Share this post


Link to post
Share on other sites
Rob
Do you have [url="http://www.getfirebug.com"]Firebug for Firefox[/url]? This will help you to find the specific CSS affecting the menu and search box. The original code was: [code].searchform .searchfield { height: 13px; padding: 7px 30px 5px 7px; width: 150px; }[/code] In case you wish to restore it.

Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
cybersphere
I do have Firebug but even I find something about it, I can't read CSS and even I figured out that it is called: .menufield I wouldn't know how to write a CSS code to increase the space allocated for menu. I am sorry to say, I am in your hands.

Share this post


Link to post
Share on other sites
Rob
Sorry? Am I that bad? Lemme try again to identify it for you. I'll be back shortly. We won't let you down.

Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
Rob
This is what I'm seeing: [img]http://www.epicurus.com/wp-content/uploads/2011/12/justitia.png[/img] The CSS is on the bottom right in a red box. It reflects the HTML code just left in another red box and it's related to the overall menu area at the top of your site also framed in red. Would you try an experiment for me? Put the search box back, then change the names of some of your menu titles to shorter words. Make things like "Publications" into "Pubs" and "Services" into "SVCS" just to see where the menu goes relative to the search box.

Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
Rob Thomas
I am having the same issue with the Features. Until it can be resolved, I have had to go back to Platform Base. My impression, Cyber, is that PageLines expects us to create separate "home" and "blog" pages (did you do this?) in the section "Readings" and then individually control the feature sets on each page. In my case, I specifically did not create a "home" and "blog" page assigned under "Readings" in order to have blog posts show up as a preview on my front page. If you do have these set-up as separate pages assigned to permalinks, you should be able to control the Features for each page in the Meta section at the bottom of each page. I tried this and it worked for one of my pages that I had a feature set assigned to, but the home page simply displayed all of the features. but the home page is not a page I have in "pages" because it is the default the blog came with (if that makes sense), so I can't go in and adjust it individually.

Share this post


Link to post
Share on other sites
cybersphere
@rangelone - re: "Sorry? Am I that bad?" I'm sorry if I said something wrong. Not my intention to be rude. As requested, I have placed the 'search' field back in and left it as a standard size. I noticed that there is a padding to the left of search box. I tried to capture it with Firebug, just incase that may help you to provide the CSS code for me. http://imageshack.us/photo/my-images/814/menucf.jpg/ I have also reduced the menu 'Publications', letter by letter, until 'contact us' moved to the next line. In Safari, I could have 'Publi' and everything appears on one line. However, in Firefox, it was 'Publ'. Thank you! Paul

Share this post


Link to post
Share on other sites
cybersphere
@daddypony - re: "PageLines expects us to create separate "home" and "blog" pages" - I'm not aware that PageLines ever placing design limitations. Especially one where a blog can NOT be on the home page. That would limit SEO capabilities. However, I do thank you for reading and posting on this thread. I'm sure with many people's help, I will be able to figure out all the 'ins' and 'outs' of Pagelines platform! (...well, enough to make a site)

Share this post


Link to post
Share on other sites
Jenny
Do you still need assistance? There sure is a lot going on in this thread! :)

Jenny :: Web designer at Simple Mama (follow me at @simplemamacom)

Check out Share Me, a social sharing add-on for DMS that is super simple to set up.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×