Jump to content
Sign in to follow this  
stoltz

How do I make Vanilla Forum show up?

Recommended Posts

stoltz

I've installed vanilla forum on my web server and the forum is working as it should. But how do I make the Vanilla Forum show up with the help of the Pageline 2.0 framwork? I've been looking at the settings for the special pages (where there are templates settings for Vanilla) but I can't figure out how to get that template to show up in wordpress. I've been looking at templates you can add to a post (default, feature etc) but no Vanilla. Should I add a shortcode in the post or install the Vanilla plugin that is available at wordpress.org?

Share this post


Link to post
Share on other sites
Rob
I believe you need to get the Vanilla Forums template in the 2.0 Store under "Integrations". You have to implement that integration and I believe it will appear in the Vanilla settings in the Vanilla Dashboard. The Vanilla plugin isn't the best way to go. Actually, you need to install Vanilla inside your WP installation but not inside one of the wp- folders.

Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
stoltz
The installation is done inside my wp installation, so that should be fine. I don't have the option that says integration so I cannot see the vanilla forums template. Your store seems to be different compared to mine - I'm using the one through Launchpad I have Pageline 2.0 developer if that matters.

Share this post


Link to post
Share on other sites
Rob
This is what I see in PageLines 2.0 Developer edition: [img]http://www.epicurus.com/discussion/wp-content/uploads/2011/12/vanillastore.png[/img] Do you see something different?

Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
stoltz
Yep, have activated that one since before. Seems like the store inside pageline 2.0 and the store you access through Pageline launchpad are different. My question is still the same tho, what do I do after I've activated the Vanilla integration? It made the a choice in special templates show up, but I can't apply that template anywhere in WP. So what is the next step to make Vanilla show up on your WP-site?

Share this post


Link to post
Share on other sites
kastelic
First off I have to tell you i've never installed Vanilla before, so I don't know if this is the best or recommended way but I just did it and this is what happened. 1. I installed the Vanilla Forums Plugin. 2. I went to vanillaforums.com and signed up for the free account. 3. In my WP admin I clicked Vanilla Forum in the settings and pasted in the URL for my forum that I got when I signed up. 4. New options appeared in the Settings sidebar "Embed Vanilla". I clicked that and You will see an option for "Forum Location in Wordpress". This shows where the forum is located on my wordpress site. Is this at all what you are looking for or am I totally off base?

Share this post


Link to post
Share on other sites
stoltz
That is what I've done in the mean time until someone can explain how to add Vanilla to wordpress via Pagelines 2.0. The way I've understood it is that adding vanilla through the framework enables vanilla to make use of the css styles that are already in place through the framework look and feel. The way you (and me too) solved it so far is a crude solution and if you look in the framework (dev edition), then there is a special page for Vanilla forums. It's in the menu special and is visible if you've activated the Vanilla integration through the store inside Pagelines 2.0 My problem is that I don't know how to initiate that special page.

Share this post


Link to post
Share on other sites
stoltz
Finally! I got a mail from Pagelines support that explains how the integrations are supposed to be used. Here is the link to the document solves the issue - I hope it might help you too. http://www.pagelines.com/wiki/index.php?title=How_to_Use_Integrations

Share this post


Link to post
Share on other sites
Gavin_
If you already have a vanilla forum running and are about to install pagelines 2.0 is there a way to still integrate? thanks

Share this post


Link to post
Share on other sites
stoltz
Yep, I'm hosting my own vanilla forum and and the integration between vanilla and pageline 2.0 is done through a special pageline theme for vanilla. Run that theme inside vanilla, and then activate your integration and it should be up and running.

Share this post


Link to post
Share on other sites
Rob Thomas
Thanks for this information Stoltz. I am having huge problems with Pagelines 2.0 so I can't activate it without breaking my site right now. However, can I ask a dumb question? I did add the plug-in, but I did not get an account with Vanilla because I do not want to be hosted (I can't possibly afford 50 a month). I just downloaded the software for free. However, the installation instructions are kind of retarded. I am not sure which folder top put Vanilla in. I put it, for now, in the main folder for my blog. Does it need to go in wp-admin or wp-content? Thanks.

Share this post


Link to post
Share on other sites
Rob Thomas
Okay, I figured it out. I shouldn't try to work when I'm sick. All of the docs were on the site and not with the download.

Share this post


Link to post
Share on other sites
quelyn
So I am trying to activate the Vanilla plugin on the integrations tab and I see this: [img]http://www.emocrap.com/vanilla.jpg[/img] When I log out my account from within the template, then I can see the Login button there, but once I log in, nada. So I am kind of stuck and I can't figure out how to activate it.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×