Jump to content
Sign in to follow this  
snowdaypress

Suddenly there are grey boxes over my main navigation menu - how to remove??

Recommended Posts

snowdaypress

I've searched and can't find anything about this. I have Platform Pro and have just been working on my logo/header and trying different pictures on my home page and suddenly, there are now grey boxes over the nav menu when I hover over them and a permanent box over the menu for which ever page I'm on. I've been doing this for over a month and they weren't there before -- now I can get them off. I feel like it should just be a setting since I haven't changed any code, but I didn't change any of the settings for this either (that I'm aware of). Would really appreciate help with this -- trying to launch site soon. (btw, I'm really new to this - not a developer, and have been teaching myself slowly, so please bear with me!) THANKS!! site is boathouseandbarn.com

Share this post


Link to post
Share on other sites
weltraumaffe
Try this in your custom css [code].main-nav li.current-page-ancestor a, .main-nav li.current_page_item a, .main-nav li.current-page-ancestor ul a, .main-nav li.current_page_item ul a {background: transparent !important} .menu-item a:hover {background: transparent !important;}[/code]

Share this post


Link to post
Share on other sites
snowdaypress
Hi - Thank you so much -- that worked part of the way. It removed the box from the page I'm sitting on, but looking at it, I'm pretty sure it used to just underline the tab when I hovered over it, which I like better. My sight again is site is http://www.boathouseandbarn.com and for example, it used to work like it does on this site: http://acreativemint.typepad.com/ Thank you so much again!

Share this post


Link to post
Share on other sites
catrina
Please add this CSS (remember to remove the previous CSS you have for the menu-item hover): [code].menu-item a:hover {background: transparent !important; border-bottom: 1px solid #cccccc; padding-bottom: 2px;}[/code]

Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
snowdaypress
It seemed like that should work, but it didn't. I tried removing the previous poster's code but that didn't work, so I put it back and just added yours. Still giving me the grey box when I hover instead of the underline. Any ideas?

Share this post


Link to post
Share on other sites
snowdaypress
p.s. Thanks so much trying -- hopefully there will be a solution!

Share this post


Link to post
Share on other sites
catrina
Try this instead: [code]ul#menu-nav li.page_item a:hover {background-color: #fff; text-decoration: underline;}[/code]

Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
snowdaypress
Okay, it's is REALLY close. Now it's working on all of the menu pages except Home and the drop-down menu under shop. Weird! Does that make sense? Here is the code I've added so far for reference. Thanks!!! .main-nav li.current-page-ancestor a, .main-nav li.current_page_item a, .main-nav li.current-page-ancestor ul a, .main-nav li.current_page_item ul a {background: transparent !important} .menu-item a:hover {background: transparent !important;} ul#menu-nav li.page_item a:hover {background-color: #fff; text-decoration: underline;}

Share this post


Link to post
Share on other sites
catrina
Remove the code you've added so far and add this: [code]ul#menu-nav li.page_item a:hover, ul#menu-nav li.page_item a:hover {background-color: #fff; text-decoration: underline;} ul.children li.page_item {background-color: #fff;}[/code]

Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
snowdaypress
Sorry ... It's a little closer ... now the box is off the drop-down menu, but is still on Home and on the word "Shop" when I go to the drop-down. This is like a puzzle ... thanks again for helping.

Share this post


Link to post
Share on other sites
catrina
Try: [code]ul#menu-nav li.page_item a {background-color: #fff;} ul#menu-nav li.page_item a:hover {background-color: #fff; text-decoration: underline;} ul#menu-nav li.current_page_item a:hover {background-color: #fff; text-decoration: underline;} ul.children li.page_item {background-color: #fff;}[/code]

Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
snowdaypress
That's it! Yay! Thank you so, so much!! I wonder if I will ever be able to troubleshoot like this -- brilliant. Thanks again ...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×