Jump to content
Sign in to follow this  
arretx

Excerpts on is_home() in Magazine Layout

Recommended Posts

arretx

This isn't the first post I've seen about this, but none of the answers seem to solve the problem. If I am in magazine layout mode with a single post to be displayed as a full post, I would expect a full article at the top with subsequent articles in excerpt mode below the first post. That part works, however, at the top of the first full post, the excerpt is displayed and then the article repeats itself. If I adjust the settings in Pagelines setup, I can get the excerpt to go away, but then it goes away on all of the smaller articles on the home page. What's the solution for this?

Share this post


Link to post
Share on other sites
kastelic
Here's a quick and dirty solution. Paste this in Custom Code -> Custom CSS: [code] .home .fpost .post-excerpt { display: none; } [/code]

Share this post


Link to post
Share on other sites
jackirenee
I added this code and now have the full content on the first post and excerpt on the rest. I would like the thumbnail (feature image) to show up for the excerpts but not that full post. Any way to do that?

Share this post


Link to post
Share on other sites
catrina
Can you post a link to your site? CSS can be used to hide the excerpt for only the full post. Also, it can be used to hide the thumbnail for the full post.

Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
catrina
I don't see the excerpt showing up for the full post at the top. Did you manage to hide it? Add this CSS to hide the thumbnail in the full post: [code]div.format-standard img.alignleft {display: none;}[/code]

Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
jackirenee
The excerpt is not the issue now, but the thumbnail. I will try this code and see if that works. Do I put this in Custom CSS?

Share this post


Link to post
Share on other sites
jackirenee
Thanks, except this didn't seem to take the thumbnail out but the actual image I had in the post (it was at the very beginning of the post before any text and aligned left. Here is an example of the post it affected http://www.theravensspell.com/2011/12/5-friday-favorites-21/ There was an image at the very beginning of the post (the same image was used as the thumbnail).

Share this post


Link to post
Share on other sites
Jenny
If the last code didn't work, then you should remove it from your custom CSS. Are thumbnails displaying in all of your pages incorrectly? If show, make sure you have the proper settings in Blog and Posts -> Post Thumbnail section.

Jenny :: Web designer at Simple Mama (follow me at @simplemamacom)

Check out Share Me, a social sharing add-on for DMS that is super simple to set up.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×