Jump to content
Sign in to follow this  
17sirens

Magazine Mode- Is there a way for me to control the number of words that display on full-wdith post?

Recommended Posts

17sirens

I'm currently using Platform Pro and I have selected the magazine layout mode for my blog. I'd like to have my 1 full-width post to show more words, while keeping the other post "clips" the same. Is there a way for me to accomplish this? here is my site: http://17sirens.com

Share this post


Link to post
Share on other sites
kastelic
There may be a filter that can do this, I'll mark for the devs.

Share this post


Link to post
Share on other sites
Rob
I'm not the developer and hopefully he'll chime in on this soon. However, to give my own view... yes and no are the answers to your question. I can't see how you can limit excerpt length in one modality vs another. However, there are some relatively rudimentary steps you can take to help yourself. First, as a general rule of thumb in good journalism or writing skills, your first paragraph should summarize the topic of the rest of any article. Still more accurate, the first sentence should set the tone for everything to come. My personal method is simply to copy the first sentence of each post and paste it into the excerpt field. This way I have control and the visitor gets a relatively accurate feel for what the post is about. There are plugins. This is one http://wordpress.org/extend/plugins/character-count-excerpt/ which allows you to do a character count, but I doubt seriously it will let you specify the length for magazine mode. Another, http://wordpress.org/extend/plugins/auto-excerpt-everywhere/ will also let you limit length, but not by mode, yet it will pick up the first few words (that you specify by length) and creates automated excerpts. Best practice therefore, whether using one of these plugins OR, doing it yourself is to be a good journalist and craft very short, comprehensive sentences.

Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
17sirens
Thanks, I tried the plugins that you posted and I guess I'm not looking to add more characters to my magazine mode excerpts. I'm really just looking for a way to show the 1 full-width post as a full text post instead of an excerpt. When I tried adding more characters using the first plugin, it didn't include the images I had in my full-width post, which is what I was really looking for.

Share this post


Link to post
Share on other sites
Simon
answered the same question here http://www.pagelines.com/forum/discussion/comment/82056#Comment_82056

Share this post


Link to post
Share on other sites
17sirens
I just tried it that way and I broke my site :( I'm not sure what I am doing wrong with that code...

Share this post


Link to post
Share on other sites
catrina
"$new_lengnth" should be spelled "$new_length" in the code. Perhaps that could be it.

Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
Simon
The typo was in both places in the code, wouldnt have mattered ;) Updated it anyway

Share this post


Link to post
Share on other sites
17sirens
Where exactly do I put the code? When I put it in my functions.php it crashed my site lol

Share this post


Link to post
Share on other sites
Rob
I'm not sure and I believe Pross has gone away for the weekend. I'll flag this for developer attention. Please be patient to Monday when he's back.

Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
Simon
You put the code in paltformbase/functions.php

Share this post


Link to post
Share on other sites
17sirens
So I'm in Magazine mode, and I'd like my first "full-width" post to show it's full content (instead of controlling the character limit), is there a code that I could use to do that? This would show the full content of just the first "full-width" (feature) post while keeping the other posts as clips.

Share this post


Link to post
Share on other sites
Rob
The plugins or code to control excerpt length cannot distinguish between the first and second tier posts. Thus your only option will be to manually edit posts. If you want the first post to show full content, Simply copy the main content to the excerpt area for the first post. When you add a new post, you just have to edit the excerpt of the last one. It's time consuming, but if you can't use a standard format, I don't see any way to do it otherwise.

Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
17sirens
Hi Rangelone, I'm not trying to control the excerpt length. The excerpts work fine, I'm just trying to have it so that my full-width post shows the full content and the rest of the post clips show excerpts. I've seen this done on other blogs, just not sure how they accomplished it.

Share this post


Link to post
Share on other sites
kastelic
Here's a solution I think is what you are looking for. Go to PlatformPro -> Blog and Posts. Under Full Post Content check Posts/Blog Page. Under Post Excerpt or Summary Handling also check the Posts/Blog page. What you will have if you have magazine mode with one full-width post is the first post having the excerpt AND the full content. The clips will only have excerpts as that is what they always have. Now it is only a matter of hiding that extra excerpt which can be done easily by pasting this in Custom Code -> Custom CSS: [code] .fpost .post-excerpt { display: none } [/code]

Share this post


Link to post
Share on other sites
17sirens
Hi Kasteic, That's exactly what I'm trying to do. I did everything you said, but it just shows excerpts above each post AND the full post for everything (including the clips). I know that this method worked for a few others, so I'm not sure what's going on with my site. I'm on Platform 2.0 btw. http://17sirens.com :(

Share this post


Link to post
Share on other sites
Danny
Hi 17sirens, Did the link @pross posted to the filter not work? Did you change the post id within the code to match your post ?

Please search our forums, before posting!

Share this post


Link to post
Share on other sites
17sirens
Hi Danny, When I had Platformbase installed, that filter didn't work. Then when I upgraded to 2.0 (and Base is not installed anymore) I tried it again and it still didn't work. I also tried changing my blog/posts settings through wordpress and platform (like how Kasteic mentioned) and that didn't work either. I'm not sure if maybe I'm doing something wrong, or..

Share this post


Link to post
Share on other sites
kastelic
In the future you will want to post questions for 2.0 in the Pagelines Framework category, and 1.5 goes in the Platform Pro category. Here's the same type of solution, enable full-posts and excerpts for the blog page and paste this css: [code] .blog .post-number-1 .post-excerpt { display: none; } .blog .clip_box .entry_wrap {display:none; [/code]

Share this post


Link to post
Share on other sites
17sirens
Oh my gosh, THANK YOU SO MUCH!!!!! It worked! You guys are the best. Thanks so much for all of your help. I really appreciate it!

Share this post


Link to post
Share on other sites
17sirens
@Kastelic What would the code be if I wanted to achieve the same goal (first post would be full length and other posts would be exerpts), but in Blog Layout Mode? TYIA!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×