Jump to content
Sign in to follow this  
ksteingrandt

Feature page More button - no link in IE7

Recommended Posts

ksteingrandt

I am seting up a feature page and adding URLs to the Feature Link fields. The links work just fine in Firefox and IE8, but there are no link at all in IE7. Mousing over the More button shows no link and clicking on the button obviously doesn't do anything. I work for a government agency that only just upgraded from IE6 to IE7 (yeah, tell me about it!), so we kind of need this stuff to work in IE7. Any fixes for this?

Share this post


Link to post
Share on other sites
ksteingrandt

I should add that so far this has only happened with the White House Pro theme. Seems to work fine in iBlogPro. I will also be testing it on the StationPro and EcoPro themes.

Share this post


Link to post
Share on other sites
cmunns

Thanks ksteingrandt we'll look into it.

Share this post


Link to post
Share on other sites
Andrew

can I get a live link to the issue?

Share this post


Link to post
Share on other sites
Andrew

this is an interesting one, IE7 really is hard to deal with. I'll do some homework.

Share this post


Link to post
Share on other sites
Andrew

Ok, patched this one: temp fix is to add this: `.fcontent a.featurelink{height: 25px;width: 100%;padding: 0;zoom: 1;}` to your custom css

Share this post


Link to post
Share on other sites
jed_defalcocomcastnet

Hi, We are experiencing the same problem. The more buttons are showing in Ff3 and IE8, but not in IE7. We are using WhiteHouse Pro 2 at http://vettainvestments.com. We tried the temporally fix, but all it did was to mess up the buttons in Ff3 and IE8. Do you have an update of the script or a different fix? Thank you.

Share this post


Link to post
Share on other sites
bryan-hadaway

Upgrading WhiteHousePro along with the patch should to the trick. Thanks, Bryan

Share this post


Link to post
Share on other sites
jed_defalcocomcastnet

Where can we get the patch? Is the patch just a general patch for the theme as a whole or for the Feature script? Is it a patch for WHP 2 or 3 only. I am asking, because we have already put in time to customize the theme and if we are to upgrade we will have to spend time applying customizations again.

Share this post


Link to post
Share on other sites
bryan-hadaway

This is the patch: `.fcontent a.featurelink{height: 25px;width: 100%;padding: 0;zoom: 1;}` But, I think it only applies to the new theme version. A few things to consider, when upgrading, you'll always have your old theme to revert back to in case there's trouble. Also, have you edited any of the files, header.php, style.css? If not, you should be fine... you're settings are all saved in the database, they're not theme dependent. Thanks, Bryan

Share this post


Link to post
Share on other sites
jed_defalcocomcastnet

As previously mentioned, the "patch" did not work. In addition to changing theme settings, we have put in time customizing the theme files.

Share this post


Link to post
Share on other sites
cmunns

J The patch will likely work only if the theme didn't change naming conventions from v2 to v3. So a live link to your site would be helpful. Also if you are going to use a fix for IE7 and don't want it to mess up other browser rendering then you should create an IE7 specific style sheet with rules to be used if it's IE7

Share this post


Link to post
Share on other sites
jed_defalcocomcastnet

From my earlier post, the website address is http://vettainvestments.com. We have not changed any naming conventions. We have only made layout changes to some of the templates. We tried the "patch" which was posted by arpowers. And per his directions, it was placed in the custom css under the WHP Options page from within the admin interface. But that did not fix the problem with the IE7. The buttons still do not show. We have resolved the issue with the other browsers by using an if statement.

<!--[if IE 7]>
	.fcontent a.featurelink{height: 25px;width: 100%;padding: 0;zoom: 1;}
	<![endif]-->

Share this post


Link to post
Share on other sites
cmunns

Okay I've figured it out. Add `text-indent:0;` to that selector.

Share this post


Link to post
Share on other sites
jed_defalcocomcastnet

Thank you Cmunns. The text-indent should be set to 7.8%. That puts the button in the middle of the left block, just like it appears normally in other browsers. If it is 0 then the button is all the way to the left. Here is the final code, which works in Ff3.6, IE7, IE8 and IE8 compatibility mode.

<!--[if IE 7]>
	.fcontent {};
	.fcontent a.featurelink{text-indent:7.8%;height: 25px;width: 100%;padding: 0;zoom: 1;}
	<![endif]-->
Without declaring the selector it does not work.
.fcontent {};

Regards, Alexandar Tzanov Innovadix.com

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×