Jump to content
Sign in to follow this  
ryanjohnjackson

Phone number in footer won't show on iphone...

Recommended Posts

ryanjohnjackson

Ok, Phone number in footer won't show on iphone. So far I'm guessing this is due to how iphone looks at phone numbers on a page since it makes them links. In wordpress/platform pro/footer/full width sidebar/text widget I have the address and phone number of my complex. Like this:

Office: 914-421-0000
Shows in linux/windows7 on Firefox 7/8 but not on iphone 4.xx safari. It literally just blanks out the number. The word "Office:" shows correctly and positioned as if the number is there but invisible. I removed the html around it and it still didn't show up. The number does show elsewhere on the page and I have
around everything else in the footer. All else shows. I just thought to try to somehow make it a link and see if it shows. I'll see if that works.

Share this post


Link to post
Share on other sites
catrina
I don't use an iPhone so I can't check it out, but make it a link and post here again if it works.

Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
ryanjohnjackson
Hmm... is there a setting i may have turned on/off that prevents links from showing in footers? If so then that's why It won't show in iphone but does show in desktop web browsers. Once I forced it to be a link it disappeared from my desktop browsers as well. Likely a n00b issue on my part.

Share this post


Link to post
Share on other sites
ryanjohnjackson
Catrina, Once I forced it to be a link it disappeared from all browsers.

Share this post


Link to post
Share on other sites
catrina
To make text a link you'll need this code: [code]914-421-0000[/code] (The # sign will make the text a link, but it doesn't go anywhere when you click on it - you just stay on the same page)

Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
ryanjohnjackson
Thanks, It didn't work though. I really don;t want it to be a link but I was testing if that was a part of the issue and it turned out right. In iphone all phone numbers turn into links for calling. So this number is in 2 places. Content area and a text widget in the footer. On my iphone the content version of the number, which iphone turned into a link, shows up. The footer version disappeared. Anything else I turn into a link in the footer disapears from iphone, ff/linux, ff win7. It has to be a setting or a bug. I'm using 3.2.1 and latest platform release 1.x.x.

Share this post


Link to post
Share on other sites
ryanjohnjackson
Ok I tried another site that I setup. The 3 differences are settings, custom css and theme. I already commented out the custom css and it didn't fix it. The other site is running as a child theme. this site isn't a child theme. It's just straight platform pro. I was going to remake it from a child theme tonight anyway so maybe that will fix it. If not maybe it has to do with the discussions settings? I have that trackback stuff off? not sure?

Share this post


Link to post
Share on other sites
ryanjohnjackson
Thanks, I'll do that tonight. That's the theme I'm running the other site from that doesn't have this issue.

Share this post


Link to post
Share on other sites
Rob
In Wordpress the italics tag is not . That could be your problem.

Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
ryanjohnjackson
Range, I have the problem even without tags.

Share this post


Link to post
Share on other sites
Jenny
Have you tried changing the way you're displaying the number, such as Office: 914.421.0000

Jenny :: Web designer at Simple Mama (follow me at @simplemamacom)

Check out Share Me, a social sharing add-on for DMS that is super simple to set up.

Share this post


Link to post
Share on other sites
ryanjohnjackson
Wow, major FAIL on my part. Figured it out. The link color for that specific theme was accidentally the SAME as my footer color. SO when iPhone made it a link it would "disappear". I didn't do the good ol' select all because I was getting use to using firebug and saw the code there already. Thanks for the help! Sorry about the fail.

Share this post


Link to post
Share on other sites
Danny
HAHA! I've done this in the past, thanks for letting us know!

Please search our forums, before posting!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this