Jump to content
Sign in to follow this  
xtrme

IE 7 puts spaces between the main horizontal menu and drops the last item to a new row (below)

Recommended Posts

xtrme

I know there must be an easy css fix but trying to locate one in the discussions area of the pagelines site is a nightmare. Definitely not intuitive. Please help

Share this post


Link to post
Share on other sites
catrina
I don't think there has been a CSS fix posted for this yet. Can you please post a link to your site?

Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
xtrme
http://xtrme.dreamhosters.com

Share this post


Link to post
Share on other sites
catrina
I'm not sure how the spaces can be eliminated but perhaps decreasing the padding for the menu items can ensure that the last item doesn't drop down to a new row. Try adding this CSS to Custom Code > Custom CSS: [code]ul#menu-main-menu li.menu-item {padding: 5px; padding-top: 10px; padding-bottom: 10px;}[/code]

Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
xtrme
No, that made it worse - it increased the gap. The last menu item isn't being forced down because of lack of space. It should easily fit beside the others horizontally.

Share this post


Link to post
Share on other sites
Kate
If I had to guess, I would say it's ignoring a CSS declaration. See, the ".main-nav" ul class is set to 780px wide. However, when you choose not to display the search bar, a new declaration, using ".main-nav.nosearch", is added. And, a width of 1000px is applied. It's possible IE7 is ignoring this adjustment. Please try this in your custom CSS: [code]#primary-nav ul.main-nav.nosearch{width:1000px !important;}[/code]

Share this post


Link to post
Share on other sites
xtrme
Thanks! That worked for aligning the menu. There seem to be a lot of CSS issues with IE7: The main menu displays the hover colour by default and puts another colour on hover. The search widget is almost gone. The "more" text on the feature sliders is dark blue instead of white. The bottom footer is not centered on my site but it is on the pagelines site. Is there any way to fix all these (and probably other things I haven't noticed yet)?

Share this post


Link to post
Share on other sites
xtrme
Found the problem. I had added some code to the header.php file that messed everything up in IE 7.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×