Jump to content
Sign in to follow this  
chisim11

Can someone help me fix this Main Navigation alignment issue for good?

Recommended Posts

chisim11

Refer to site http://tinyurl.com/3slhflz. I asked this question before in the past and the answers did not resolve the issue. Was also told to review the following thread > http://www.pagelines.com/forum/discussion/5906/center-navigation-for-platform-pro/p1 , again w/no success. Now after trying to have this issue fixed to no avail, decided to leave it alone. Unfortunately, everytime I have to add, delete or change any of the words, the navigation starts to shift to the right, instead of aligning/centering itself. Also every time I try to zoom in or out(ctrl +/-), it does not keep its position. At first I thought it was the embedded video or the pics but whenever I look at the logo on the top and the logos on the footer along w/the margins on the video and pics, it is very clear that it is the navigation. The codes below is everything that I have on the custom code area, and maybe some of this stuff is conflicting with it. body{} body div.branding_wrap {text-align: center;} ul#sub-menu li.menu-item {text-transform: lowercase;} #nav_row.main_nav, ul.sf-menu ul li {border-bottom: 0;} #featurenav {background-color: #000000;} #feature-footer {background-color: #000000; border: 0;} #feature-footer .feature-footer-pad {border:0; padding:0; margin-left: 14px;} #primary-nav{width:974px; margin: 0 auto;} #feature-footer{margin-left:115px;margin-top:5px;} sorry for the long explanation. Can someone help me? Thanks.

Share this post


Link to post
Share on other sites
catrina
[code]#primary-nav{width:974px; margin: 0 auto;}[/code] ^ It could be something in this. Try removing [b]margin: 0 auto;[/b] from it.

Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
chisim11
Unfortunately, it does not work. The whole navigation pretty much moves to the left. not centered. Any other suggestions?

Share this post


Link to post
Share on other sites
Jenny
You need to adjust it using the margin-left CSS. Just adjust it left or right (negative or positive) to move the bar. I haven't been able to figure out how to center it automatically.

Jenny :: Web designer at Simple Mama (follow me at @simplemamacom)

Check out Share Me, a social sharing add-on for DMS that is super simple to set up.

Share this post


Link to post
Share on other sites
chisim11
Jenny, Are you referring to: #primary-nav{width:974px; margin: 0 auto;} If I place a -5, for instance #primary-nav{width:974px; margin: -5 auto;} it will take the nav all the way to the left. Can you provide the code? Thanks, Sorry, not very knowledgable with CSS code.

Share this post


Link to post
Share on other sites
catrina
You must take out the "auto" bit so that it looks like this: [code]#primary-nav {width:974px; margin: -#px;}[/code]

Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
chisim11
does not work.

Share this post


Link to post
Share on other sites
catrina
Try removing this altogether and check to see if any difference is made: [code]#primary-nav{width:974px; margin: 0 auto;}[/code]

Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
chisim11
I had already tried that before.

Share this post


Link to post
Share on other sites
chisim11
main nav all moved to left. I just cant believe there is not a solution for something like this.

Share this post


Link to post
Share on other sites
Danny
Hi Chisim11, Can you give this a try please: [code] #primary-nav { margin: 0 auto; width: 1200px; } #nav_row { border-bottom: 0 none !important; margin: 0; padding: 0; text-align: center; } .main_nav ul li { display: inline-block; float: none !important; padding: 0; } [/code] Remember to backup any code you currently have, just incase.

Please search our forums, before posting!

Share this post


Link to post
Share on other sites
chisim11
Danny, Removed prev codes. entered the ones above. Did not see difference on 1st page which is the video. In other words, if you try to ctrl+/-, it does not align accordingly. On the other hand, it does align with all the other pics. I believe there was an issue with the width at 974px to begin with but have no idea why it was 974px to begin with when the actually width is in fact 1200. I thank you for your help thought.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×