Jump to content
Sign in to follow this  
anlinares

Quick cforms styling question

Recommended Posts

anlinares
http://outdooraddixtions.com/contact/ I have a very simple contact form for the moment and have deactivated the cforms styling. Is there an easy way that I can make the input boxes white? I know there is but I'm not quite sure which id to target in the css (even while looking at firebug... I'm still learning)! Thank you for your help, as always!!

Share this post


Link to post
Share on other sites
Jenny
Add the following to your custom CSS: [code].cform .area, .cform .single { background-color: #FFFFFF; }[/code] To get your comment form areas showing properly, you should add the following custom CSS as well: [code]input[type="text"], input[type="password"], textarea, #dsq-content textarea { background-color: #FFFFFF; }[/code]

Jenny :: Web designer at Simple Mama (follow me at @simplemamacom)

Check out Share Me, a social sharing add-on for DMS that is super simple to set up.

Share this post


Link to post
Share on other sites
Jenny
Actually, use this for the comment form instead: [code]#commentform textarea, #commentform input { background-color: #FFFFFF; }[/code]

Jenny :: Web designer at Simple Mama (follow me at @simplemamacom)

Check out Share Me, a social sharing add-on for DMS that is super simple to set up.

Share this post


Link to post
Share on other sites
anlinares
Looks like it should work but it isn't. Tried with '!important' but that didn't help. Suggestions? Oh, and thanks for trying to resolve an issue (comment form) that I didn't even realize I had yet. Haha! You're awesome!

Share this post


Link to post
Share on other sites
Jenny
Are you entering the code in the PlatformBase style.css? Try this: [code]form#cformsform.cform .area, form#cformsform.cform .single { background-color: #FFFFFF !important; } #commentform input#author, #commentform input#email, #commentform input#url, #commentform textarea#comment { background-color: #FFFFFF !important; }[/code] Hopefully that works otherwise I'm out of ideas.. LoL

Jenny :: Web designer at Simple Mama (follow me at @simplemamacom)

Check out Share Me, a social sharing add-on for DMS that is super simple to set up.

Share this post


Link to post
Share on other sites
anlinares
Not working. Sorry! But thank you for your help. There is a high likelihood that I may have something in my code preventing it from working but I have no idea what. However, I installed Disqus so the comments I think were automatically formatted for me. Thanks for your help!

Share this post


Link to post
Share on other sites
anlinares
I deactivated all of my plugins to see if something may be conflicting but no luck.

Share this post


Link to post
Share on other sites
anlinares
Yes. My problem for the comment area was resolved now that I am using Disqus. However, I need the input field on my contact page to have a white background so that they are visible against the black background. http://outdooraddixtions.com/contact/ Any ideas? Thank you!

Share this post


Link to post
Share on other sites
catrina
Try adding this to Custom CSS: [code]input#cf_field_1 input.single {background-color: #fff;}[/code] (It is meant to change to the first field. If it works, the CSS for the other fields can be worked out)

Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
anlinares
No, I'm sorry! Also tried with '!important' and that didn't help. I don't know what is going on but it sure is being stubborn!

Share this post


Link to post
Share on other sites
esensio
Hello, I am using the cformsII styling with custom presets...http://imgur.com/JnXDI Here's my form: http://esensio.eu/web/contact-logistics/?lang=bg I think will be better for you to use these predefined templates. Alex

Share this post


Link to post
Share on other sites
catrina
Cforms can be quite difficult sometimes... [code]input#cf_field_1 input.single.fldrequired {background-color: #fff;}[/code]

Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
anlinares
Well, maybe I figured out what part of the problem was. Maybe? I didn't realize I had to activate the lable and list IDs with the cforms style settings. So I've done that now. I went back and tried all the codes above but they still don't work. I had tried the preset style forms that esensio suggested before but was happier with the styling from the theme (minus my issue with the bg color). Anyway, I did end up tinkering with one of the predefined and got it styled suitably.... almost. Any easy way to align it left? Otherwise, it's fine. Thanks, Catrina and everyone, for your help.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×