Jump to content
Sign in to follow this  
riechersm

URL change

Recommended Posts

riechersm

Hi all- The page URL automatically assigned to new pages is so inelegant. Our Buddhist Center is offering classes in Brooklyn Heights, and I make a page and it gets named: http://www.brooklynmeditation.org/wordpress/?page_id=44 I would much prefer it be assigned something like http://www.brooklynmeditation.org/wordpress/Heights (the wordpress folder will be gone when we make the site our functioning site, so actually it would be http://www.brooklynmeditation.org/Heights) How can I change the URL for each page? THANK YOU!

Share this post


Link to post
Share on other sites
Rob
The solution is in Dashboard > Settings > Permalinks. Search engines prefer more specific names, the favorite being the ID and Postname or Postaname and ID. The code is [code]/%postname%/%post_id%[/code] Yielding http://www.brooklynmeditation.org/Heights/44 You can flip them around to [code]/%post_id%/%postname%[/code] Yielding http://www.brooklynmeditation.org/44/Heights Or, if you prefer, you can leave out the post_id to produce the effect you originally specified.

Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
riechersm
Hi Rangelone Thanks for your answer. Just to be clear, you are saying that Search engines prefer something like http://www.brooklynmeditation.org/Heights/44 to http://www.brooklynmeditation.org/Heights/? Why don't we see that kind of thing more on important or popular websites, in that case? Thank you for your patience.

Share this post


Link to post
Share on other sites
Rob
Probably because website publishers try to "prettify" their URLs to eliminate numeric codes. However, some major sites use a variety of options... let me show you http://www.cnbc.com/id/45246430 CNBC uses "id" and the numeric post id code only. http://www.cnn.com/2011/11/11/world/europe/greece-main/index.html?hpt=hp_t3 CNN uses the date and categories with index.html plus a post ID (customized) You can read more on this here: http://codex.wordpress.org/Using_Permalinks

Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
riechersm
Genius. Very thorough answer. You guys do a great job over here.

Share this post


Link to post
Share on other sites
Rob
We try! And thanks for being our client! By the way, you're going to love our upcoming 2.0! It's packed with all sorts of great new options, features and other goodies.

Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
riechersm
That's exciting. Is it going to mess up my whole world? Like if I get the widget thingy you recommended?

Share this post


Link to post
Share on other sites
Rob
She's right. Not only about our upcoming 2.0, but about Widget Logic. It won't mess up anything. Great tool and well supported.

Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
riechersm
I've installed it, and it seems to work beautifully. It is fulfilling my layout wishes admirably.

Share this post


Link to post
Share on other sites
riechersm
Hi Rangelone Thanks for your help on this. Above, you wrote: "You can flip them around to /%post_id%/%postname% Yielding http://www.brooklynmeditation.org/44/Heights" and I did that in the "custom permalinks" section under settings. Now it looks BEYOOTIFUL, but it is not displaying page id#'s, so een tho it looks so nice and has fulfilled my original wishes, it is not fulfilling my NEW wishes, givent ot me by you, to really please those search engines. What do you think I should do now? iS it something to do with "page_id" instead of "post_id" Thanks again, you all are a wonderful help. I must confess that I'm really surprised and impressed at how well supported this is!

Share this post


Link to post
Share on other sites
Rob
On your last note... we do try a little harder than most to make our clients happy. Okay. When you made the changes to the Permalinks, down below on the Permalinks settings page there's code that often appears for the .htaccess file. You may need to copy that code and paste it into the .htaccess file in your site. Alternatively, you can FTP into the site, navigate to the .htaccess file and CHMOD it to 777 (temporarily). Then, go back to Permalinks, do a hard refresh of the page (Shift and F5 on a Windows machine) and simply re-save the settings without changing a thing. Check to see if you still get the 404 error. If not, then just CHMOD .htaccess back to 644. I'm glad you're happy with the URL structure I suggested.

Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
riechersm
uh oh. You started talking crazy talk again. How do I post something in the .htacess file "in my site?" sorry.

Share this post


Link to post
Share on other sites
kastelic
When you install Wordpress it creates a file called .htaccess in the directory that you installed it in (usally the root directory of your site) You will need you access your site files with an FTP program or your webhost's file browser to modify it.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×