Jump to content
Sign in to follow this  
qbanguy

Page Attributes Tempaltes

Recommended Posts

qbanguy

Perhaps I'm doing something wrong, but I have added a custom page template, with a given name "Homepage". I can see this template on the "Template Setup". However, when adding a new page, I was hoping to find such template in the template selection list; under the "Page Attributes" panel, but it is not showing up. Any ideas? thanks in advance.

Share this post


Link to post
Share on other sites
Danny
Hi Qbanguy, When you added the new custom page template, did you register the template in your base functions.php file?

Please search our forums, before posting!

Share this post


Link to post
Share on other sites
qbanguy
Yes I did, it is registered. I noticed that on the Template selection now it display a "Custom Page" option. However, it doesn't display the names of the other custom pages that I created, which are registered and I can add/remove sections on the Template Setup section. How does the theme know's which template to use when this option is selected from the page attributes?

Share this post


Link to post
Share on other sites
Danny
So you added the code to register the template, you can see it on Template Selection and even add sections to it but not on the Page attributes section, this is quite strange. Although you probably have, do you have Platform Base enabled as your active theme ?

Please search our forums, before posting!

Share this post


Link to post
Share on other sites
qbanguy
It is quite strange, but thats is the behavior that I'm seeing. And yes the base template is enabled.

Share this post


Link to post
Share on other sites
qbanguy
I found out what was the issue. I think is not apparent enough to indicate a template name as a comment inside a custom page, as indicated: /* Template Name: Page Name */ As a programmer, I believe that indicating a variable in a comment block is not traditional. Therefore I thought that it was just a comment and it wasn't important. Anyways thanks for all you help.

Share this post


Link to post
Share on other sites
Danny
Thanks for informing us and happy to hear your issue has been resolved!

Please search our forums, before posting!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×