Jump to content
Sign in to follow this  
rainbowmosaics

Lightbox plugins have stopped working in iBlog Pro 4

Recommended Posts

rainbowmosaics

Hi! I had previously installed two lightbox plugins Fancy Box and Lightbox Plus for WP that had worked fine. I recently tried using a another theme for my blog and accidentally hit ACTIVATE instead of PREVIEW. Of course I immediately reverted back to iBlogPro 4 but now none of my Lightbox plugins are working. Im wondering if something got wiped out when I switched themes momentarily. When I go to my blog's home page and click on a post's photo, instead of activating the Lightbox and displaying a large overlayed image, it just goes to a page showing the photo and then I click on that and it goes to an html page showing the photo. Is there something I can do to get these Lightbox plugins working again in iBlogPro 4? Thanks and ever repentant for even THINKING about trying another theme, :) Flo

Share this post


Link to post
Share on other sites
rainbowmosaics
sorry...URL is www.flominton.com so you can see how the lightbox is not working

Share this post


Link to post
Share on other sites
rainbowmosaics
ok...now FancyBox is working but only after I click the photo in the post, go to a page with just the photo posted and then click again. It used to work right from the post excerpt on the home page itself. Is there something I can modify in the theme to get it back to the point where the Lightbox plugins work right from the post excerpt like before without having to click the photo, go to another page and then click again?

Share this post


Link to post
Share on other sites
rainbowmosaics
solved it!!! The image was linking to the attachment page, not the image in the wp image gallery dialog!!!

Share this post


Link to post
Share on other sites
rainbowmosaics
Thanks Catrina - I did fix this problem in my most recent post by changing the link URL for the inserted image. Here is my next question then...Is there a way to setup the theme to make sure that when you insert and image to a post that the link URL automatically links to the image file and not the attachment ID? In other words have the link go to the image, not the attachment by default vs what it is doing now? I am trying to find a global setting that will reset all of the existing images otherwise I have to go back to every one of my previous posts and reset the links to the images, not the attachment ID Thanks - good karma! Flo

Share this post


Link to post
Share on other sites
catrina
From my knowledge, WordPress does this by default so the image URL must be changed manually.

Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×