Jump to content
Sign in to follow this  
msialaska

Superfish subnav going below content in IE7

Recommended Posts

msialaska

Ok. I have had to deal with the problem of IE7 needing the parents to have a z-index in order to bring the menu to the top layer. Currently it is going below one of the other navs. (Here's a screenshot: http://imgur.com/TywnI) My big problem is that I have 3 navs and pagelines has SO many parents to try to apply the z-index to. I am using the default theme with heavy custom modifications.

Share this post


Link to post
Share on other sites
Rob
You do realize that less than 3.5% of all IE users still use IE7? It's no longer even supported - by most software and web-based companies. Are you still using it?

Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
msialaska
Yes. And I am very annoyed. But when a client uses it and they are willing to pay for it - what are you going to do.

Share this post


Link to post
Share on other sites
Rob
I'm not quite sure how you can handle that particular menu configuration and achieve a reasonably desired result, BUT, that said, I can suggest you take a look at http://www.cssplay.co.uk/menus/ to find a menu that works in IE7 (lots of them there) and simply replace the menu on those pages with one that permits more options. When using that site, View Source to find the applicable CSS code. I'm sorry my answers aren't perhaps the ones you hoped for, but perhaps one of my colleagues could advise better than I, particularly if we were to see the site live.

Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
msialaska
Here's the dev site (it's still be worked on). Also, you'll notice that I had to over-ride A LOT of pagelines Design Settings since there were so many different sections with different style types. http://www.msicmp.com/web/kon/

Share this post


Link to post
Share on other sites
kastelic
Hi there, just tested this to work: [code] #kon-sections li { z-index:1000 !important; } [/code]

Share this post


Link to post
Share on other sites
msialaska
Thank you so much! I tried a million different elements but no the li. Thanks again!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×