Jump to content
Sign in to follow this  
jbrouwer

title above thumb and excerpt below thumb in magazine layout mode on homepage

Recommended Posts

jbrouwer

Hi, Couldn't find exactly what I am looking for on the forum. - In magazine mode (platform pro 1.5.1) I would like to have the title above the thumbnail and the excerpt below the thumbnail on the homepage. Take a look at www.pepperbase.com. - Further, how can I add a custom field below the excerpt on the homepage? - How can I adjust the wide of the created vertical box with the title, thumbnail, excerpt and custom field in it? Thx!

Share this post


Link to post
Share on other sites
Rob
First, your PlatformPro should be 1.5.3, so you need to upgrade, but more important, I hope you have PlatformBase activated and not PlatformPro. Please see http://www.pagelines.com/forum/discussion/14315/activating-the-correct-theme#Item_1 first before you do anything. As for the styling, there are a couple of ways to do this. If you have Firebug for Firefox installed, you can identify the CSS for each element and write and test adjustments. This will help you to get the correct CSS to add to Custom Code in the CSS Rules area. Alternatively, you can download from the wp-content/themes/platformpro a file called template.postloop.php and make adjustments there, including adding the custom bit you were mentioning. When you've saved your changes on your own computer, you upload it to wp-content/themes/platformbase. Please see these instruction docs http://www.pagelines.com/docs/template-setup and http://www.pagelines.com/docs/sections-templates

Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
jbrouwer
Thx for the respons. I am planning on upgrapding to 1.5.3, but stil testing compatibility with some plugins. I am using buddypress as well and last time this was not working properly after updating automatically. Had to update via ftp and re-install buddypress and the bp template pack to make things work again. Will this be solved next time? When updating platformpro it deletes the buddypress folders in the platformpro theme folder. I have firefox and firebug installed and already did a bit of adjusting. Already tried adjusting the template.postloop.php file and uploaded it to the base theme folder. However, I am not a developer and couldn't figure out how to rearrange the code. Could you point out which pieces of code I am looking for?

Share this post


Link to post
Share on other sites
jbrouwer
Great. Worked it out. One more thing. How can I add the value of a custom field under the excerpt? Should I add some code in the template.postloop.php file? Thx again.

Share this post


Link to post
Share on other sites
jbrouwer
I was able to display some custom fields in the excerpt of the clip in magazine mode. However I would like to style it differently from the excerpt. Hence, how can I create a seperate class in the clip in order to do this?

Share this post


Link to post
Share on other sites
kastelic
You could wrap it in ? What exactly do you need to attach the class to, which element specifically?

Share this post


Link to post
Share on other sites
jbrouwer
I would attacht the class to two custom fields and the category. I have tried tp use , but I got a syntax error on . Here is the code from the template.postloop.com: ID )): // Excerpt ?>
$investering = get_post_meta($post->ID, 'investering', true); echo 'Investering: '; echo $investering; $plaats = get_post_meta($post->ID, 'plaats', true); echo 'Plaats: '; echo $plaats; echo 'Categorie: '; the_category(); ? echo get_continue_reading_link($post->ID); pagelines_register_hook( 'pagelines_loop_clip_excerpt_end', 'theloop' ); // Hook ?>
Any suggestions?

Share this post


Link to post
Share on other sites
Kate
Since the span tag is HTML, not PHP, you would have to close and then re-open the PHP tags. Something like this: [code]ID )): // Excerpt ?>
ID, 'investering', true); echo 'Investering: '; echo $investering; $plaats = get_post_meta($post->ID, 'plaats', true); echo 'Plaats: '; echo $plaats; echo 'Categorie: '; the_category(); ?> ID); pagelines_register_hook( 'pagelines_loop_clip_excerpt_end', 'theloop' ); // Hook ?>
Any suggestions?[/code] You'll probably have to play around with that formatting a bit. You may even want to wrap "Plaats" and "Categorie" in their own spans.

Share this post


Link to post
Share on other sites
jbrouwer
Thanks! I am getting there. Take a look at www.pepperbase.com. Two more questions :-) - How can I make sure all the thumbnails are of the same size? I already adjusted the size in the template.postloop.php file. Furthermore, resizing the thumbnails in the wordpress dashboard doesn't work... - Second. How can I align the category (e.g. "horeca&recreatie") next to the plain text "categorie", hence without the white space between them?

Share this post


Link to post
Share on other sites
Danny
Hi, To answer your questions: 1. The best thing to do is to make sure all your images are the same size, I've had a few problems in the past with sizes of thumbnails and the only way I managed to address this, was to make a template image and then use that template for all the images I was going to add to posts, therefore if all the images are the same size, there thumbnails will be the same size. There is most likely an easier and less time-consuming process but I never found it, like you I changed the thumbnail sizes and the sizes in the loop but still had issues, so the way above is the only I found to guarantee a univeral size. 2. Add the below code to Platform Settings --> Custom Code --> CSS Rules: [code] .project-details ul { display: inline-block; list-style: none outside none; margin-left: 0 !important; text-align: left; } [/code]

Please search our forums, before posting!

Share this post


Link to post
Share on other sites
jbrouwer
Hi, 1. I just hoped for a less time consuming solution, but I have just manually resized the images and that works fine. 2. I added your code to the base style sheet, but it doesn't work. Cheers

Share this post


Link to post
Share on other sites
Rob
The code provided above doesn't go into base.css. It actually goes in Platform Settings --> Custom Code --> CSS Rules as Danny instructed.

Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
jbrouwer
Solution on 2 was to change the php code in the template.postloop from "the_category();" to "the_category(' ');"

Share this post


Link to post
Share on other sites
jbrouwer
@rangelone thanks, tried that as well, but didn't work. For my understanding, what happens with the code you put in Platform Settings --> Custom Code --> CSS Rules?

Share this post


Link to post
Share on other sites
kastelic
That code ends up at the bottom of dynamic.css which is a css file created dynamically from all the settings in the PlatformPro backend. As for your other questions, it look like you may have gotten them solved? If not it might be good to start a new thread.

Share this post


Link to post
Share on other sites
jbrouwer
Thanks. Yep. Questions are solved. Thanks again!

Share this post


Link to post
Share on other sites
Rob
I presume I can close this issue based on your last statement. Glad your issue was resolved.

Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×