Jump to content
Sign in to follow this  
blgh

How to fix Warning: array_shift() [function.array-shift]: The argument should be an array in /hermes

Recommended Posts

blgh

Hi, one of my websites that I created with PlatformPro just started displaying this at the top of each web page. I have done nothing to the site and it was fine the last time I checked the site. Any ideas on how to fix? Warning: array_shift() [function.array-shift]: The argument should be an array in /hermes/bosweb/web131/b1316/ipg.penandpixelscom/wordpress/wp-content/themes/platformpro/admin/class.debug.php on line 166

Share this post


Link to post
Share on other sites
Rob
It appears this is coming from a conflict with a plugin. Please deactivate your plugins one by one. Between each deactivattion, do a hard refresh on your browser when viewing your site. On a PC, it's "Shift+F5". See if that deactivation restores your site and removes the warning.

Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
blgh
Hi, Thanks. I just deactivated each plugin and the error message is still appearing. I talked with my host company who said that the error message seems to be coming from a problem with the theme based on the error message. They have not made any changes. I know PageLines is updating and am wondering if this is causing the problem as I've done nothing to the site (no new plugins, no adding content, etc.) for months. I have another Wordpress site with the same account/host, different theme, and it's doing fine. The host turned off the error display on their end so it's not public to the world but it's still appearing on the back end and I'd like to take care of this quickly. Also, does anyone know of the best way to notify the PageLines developer of this problem as they may have some insight. I'm using Platform Pro. Many thanks.

Share this post


Link to post
Share on other sites
Rob
We didn't send through any changes. Try this. Go to Dashboard > Settings > Permalink and without changing anything. Just save your settings. See if that gets rid of the problem. Have you recently changed any settings on anything, added a plugin, modified a CSS or files of any kind?

Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
blgh
I just tried the Permalink and no-go. I haven't added anything to the site, nor modified any settings or CSS. The host company is blocking the Warning message from appearing through modifying ini files but it's still on the back end.

Share this post


Link to post
Share on other sites
Rob
The only other thing I can think of is a plugin that has either been upgraded and caused the problem, or perhaps expired and caused it. To the very best of my knowledge, we've not made any changes and when we do, it's bundled up into a revision and an upgrade is made available. Even if you have auto updates, we'd see a revision in the number of the component and there've been none.

Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
blgh
Hi, Thanks for your time. I'm still plugging away trying to find a solution to this. I'll let you know what we turn up.

Share this post


Link to post
Share on other sites
Rob
Did you at one point have Global Translator loaded as one of your plugins? Wordpress is suggesting that this plugin may have conflicted with something else and written the error into the database. As a translation script, unlike many other plugins, it writes content to tables in the database. As long as they remain intact, even if the plugin is removed, the error will stay.

Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
Danny
Hi Blgh, Your issue should be resolved by updating the theme to the latest version. You're currently using version 1.40, please update to the latest version and let us know the result.

Please search our forums, before posting!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×