Jump to content
Sign in to follow this  
urbanimatic

Featured image missing in custom post types.

Recommended Posts

urbanimatic

Hi there, i'm using a plugin to show testimonials , the plugin use custom post type and it use featured image as client's photo. The issue is that when using platform the featured image option is not available...it is not a plugin error as i have the same issue with other plugins that make use of featured image and custom post type and when i switch to another theme the featured image option is there. Please advice, -Stelios

Share this post


Link to post
Share on other sites
Rob
Stelios, custom post types shouldn't really have thumbnails in them as they're usually used for such things as sliders, boxes, soapboxes, carousels, etc. Where would the featured image go? Obviously, it would present serious problems if it were placed in the text are, next to the title in a feature slider over the background.

Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
Danny
Hi Stelios, Add this to your functions.php file in /platformbase [code]// THUMBNAIL SUPPORT FOR CPT'S add_theme_support( 'post-thumbnails', array( 'post', 'YOUR CUSTOM POST TYPE NAME' ) ); [/code] So if your custom post type is Testimonials, replace YOUR CUSTOM POST TYPE NAME with Testimonials so it looks like this: [code]// THUMBNAIL SUPPORT FOR CPT'S add_theme_support( 'post-thumbnails', array( 'post', 'testimonials' ) ); [/code]

Please search our forums, before posting!

Share this post


Link to post
Share on other sites
urbanimatic
Hi Danny, That did the job :) Thank you very much

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×