Jump to content
Sign in to follow this  
Jackey

"Post Type Order" plugin messes up Article Navigation

Recommended Posts

Jackey

The Post Type Order plugin that comes recommended messes up the article navigation links. Only the backward links are correct. Does anyone else have this problem? Regards, Jackey

Share this post


Link to post
Share on other sites
Kate
Hi Jackey, I haven't heard of others having this problem, personally. But, there are some other post type ordering plugins in the WP repository. Perhaps try one of those instead?

Share this post


Link to post
Share on other sites
Jackey
I actually don't need it for the post, but I need it for the boxes and features. The other plugins do not provide that. Or they don't work at all... :(

Share this post


Link to post
Share on other sites
kastelic
link to site? What does it do to the forward links?

Share this post


Link to post
Share on other sites
Jackey
http://golfclub-stippelberg.nl/2011/09/matchplay-kampioenen-2011/ It is fixed on one post.

Share this post


Link to post
Share on other sites
Kate
Hey Jackey, I'm not sure I'm seeing the issue, sorry! It appears the top page navigation is working fine.

Share this post


Link to post
Share on other sites
Jackey
The left link is fine (previous post)... the right one should not be there on this particular page, and it does not point to the correct page in sequence.

Share this post


Link to post
Share on other sites
slingr
One thing you can do to set the correct sequence of posts is change their date. From your "All Posts" page, use teh Quick Edit option to note the Date and Time for each post. Change them appropriately so that the first post in sequence has the oldest Date/Time, etc. I've just done this for a sequential tutorial and it works fine, presuming, of course, that the Date of the post is inconsequential.

Share this post


Link to post
Share on other sites
Jackey
That is the strange thing... the dates of the posts are sequential... i.e. in the order of the posts. When I disable the plugin the links are fine.

Share this post


Link to post
Share on other sites
slingr
I see the problem. There's something strange going on with the GVB Examen post. On this page it is displayed as both the previous and the next post: http://golfclub-stippelberg.nl/2011/08/dienstregeling-de-tram-gemert/. Are you sure you don't have multiple copies of that post? Also, in the left column of your Dashboard under Posts | Re-Order, can you move the posts around to the correct order? Or, are they already in the correct order but they're not being displayed correctly in the Post Navigation at the top of the page? If you look at the posts page, where only excerpts of the posts are displayed, do they display in the correct order? If so, it would seem like the problem is specific to the Post Navigation at the top. Have you tried disabling other plugins that might be conflicting with Post Navigation?

Share this post


Link to post
Share on other sites
Jackey
Problem is known and solved by upgrading to Advanced version: [quote]Hello Jackey, The advanced version contain a different code which correctly return the next/previous post links in all situations. We had that issue before with the free version, the advanced post types orders works fine with Pagelines Themes. Thank you, Dan Support Department[/quote]

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×