Jump to content
Sign in to follow this  
taylorashley

No thumbnail images when sharing post links to Facebook

Recommended Posts

taylorashley

Hello! I've yet to figure out why thumbnail images of my photos or featured image do not show up when I share a blogpost link to my Facebook page. Can anyone help me? I've tried everything I know to do (including purchasing a "pro" sharing plugin). Thanks!! http://www.taylorbrowning.com/

Share this post


Link to post
Share on other sites
catrina
Here is a fix you can try: http://www.wpbeginner.com/wp-themes/how-to-avoid-no-thumbnail-issue-while-sharing-post-on-facebook/

Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
taylorashley
Thanks, Catrina. I tried downloading the recommended plugin to no avail...

Share this post


Link to post
Share on other sites
Jenny
What are you using to post your posts to Facebook? I've used Networked Blogs with no issues. I believe there is one that also pulls from Twitter and posts to Facebook as well. Edit: Nevermind, I see you are posting links manually. Edit 2: Perhaps try what this person has suggested -> http://blog.ashfame.com/2011/02/wordpress-plugin-fix-facebook-like-thumbnail/

Jenny :: Web designer at Simple Mama (follow me at @simplemamacom)

Check out Share Me, a social sharing add-on for DMS that is super simple to set up.

Share this post


Link to post
Share on other sites
taylorashley
I have tried all of the meta tag plugins and nothing has worked...

Share this post


Link to post
Share on other sites
taylorashley
Yes, Catrina, I just tried deactivating my plugins, still no thumbnails :(

Share this post


Link to post
Share on other sites
taylorashley
Any help you can provide is much appreciated! I have been trying to figure out this problem for months...

Share this post


Link to post
Share on other sites
Kate
Hey Taylor, Please try activating the TwentyEleven (or TwentyTen) default WP theme. Then try repeating the steps you take to post to Facebook, and see if it shows the image.

Share this post


Link to post
Share on other sites
taylorashley
Kate, When I activate the Twenty Eleven theme my thumbnails show up when I share a blog post link to Facebook! Now the trick is to get it to work with my theme... Thanks for your help!!

Share this post


Link to post
Share on other sites
Jenny
Since you got it to work with another theme, have you tried reactivating PlatformPro? Sometimes something so simple can make things work again. Let's hope so! :)

Jenny :: Web designer at Simple Mama (follow me at @simplemamacom)

Check out Share Me, a social sharing add-on for DMS that is super simple to set up.

Share this post


Link to post
Share on other sites
taylorashley
Jenny--I wish it was that simple! I tried just now and it did not work :(

Share this post


Link to post
Share on other sites
sarahdope
I'm having the same problem. I wasn't using a thumbnail previously, nor have I changed themes. It was working before the latest Pagelines update, but now it's not... :(

Share this post


Link to post
Share on other sites
Jenny
@sarahdope since you said it worked before updating, I'm going to flag this for developer review just in case something was changed with the newest version.

Jenny :: Web designer at Simple Mama (follow me at @simplemamacom)

Check out Share Me, a social sharing add-on for DMS that is super simple to set up.

Share this post


Link to post
Share on other sites
sarahdope
@simple_mama Thank you! Hopefully something gets figured out soon. :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×