Jump to content
Sign in to follow this  
chisim11

How to open a new page after clicking on a title?

Recommended Posts

chisim11

This might be a basic one but cannot find the answer. I'm currently looking at www.viewsoflajolla.com and if I go to blog > and click on "what's new" how do I do to open a new page that can be customizable. Thanks for your help.

Share this post


Link to post
Share on other sites
[Deleted User]
It looks like it opens to a category page. Are you saying you'd like to customize all category pages? Just that one?

Share this post


Link to post
Share on other sites
chisim11
all pages that have submenus like that. Is a plugin needed for that or is that avialable within WordPress? Also, any way to change the font on those submenus so they are not all in capital letters like the main menu? Thanks

Share this post


Link to post
Share on other sites
catrina
Are you referring to all pages under the "Blog" menu item link (since all of these subpages in that menu are categories)? To change font to regular capitalization, please add this CSS to Custom Code > Custom CSS: [code]ul#menu-main-header-navigation li.menu-item {text-transform: capitalize;}[/code]

Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
chisim11
Catrina added code but did not work

Share this post


Link to post
Share on other sites
catrina
Please try the following instead: [code]ul#sub-menu li.menu-item {text-transform: capitalize;}[/code]

Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
chisim11
did not work.

Share this post


Link to post
Share on other sites
catrina
Hm, I want to see if it's either the selectors that aren't working or the styling. If you add this and the text isn't put in all lowercase, it's an issue with the selectors: [code]ul#sub-menu li.menu-item {text-transform: lowercase;}[/code]

Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
chisim11
did not. however, it is not a big concern. Im more concern about the opening of a new page or as kate mentions above a "page category". cant find how to do that. in other words, after clicking a submenu that it will take you to a separate page where i can have a blog, text, pics, etc.

Share this post


Link to post
Share on other sites
kastelic
You can make any page, and then set it as a dropdown menu item by making a custom menu in Appearance -> Menus. To have that page display blog posts though, you need a plugin, or use custom code in functions.php

Share this post


Link to post
Share on other sites
chisim11
Kastelic, I created the top navigation menu on my site, "home", "contact", etc by adding/creating them as parent pages and adding additional pages as child/sub pages. But from what I'm reading these should have been created as menus, Is that right?

Share this post


Link to post
Share on other sites
Rob
You should have a primary menu in which pages, categories or custom links may be set as parent, child or grandchild links. Is that your current setup? Or, are you just using the default, which adds pages automatically?

Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
chisim11
No pages were added automatically. I originally created the menu(primary navigation) by adding each individual parent pages via pages attributes. In other words, did not go thru > Appearance > menus, etc. So, when I finished creating the primary navigation, started to add additional as child pages( guess, would be called subnavigation). The main menu or primary nav had the little arrow on the side and will drop the menu down so I was able to see the subnavigation. I was able to point to certain links and it was fine. However, whenever I wanted to open a new page/blog or anything after clicking on any of the submenus or child pages, I would not get anywhere. So, then I thought that maybe it was because I had no created the main menu or primary nav via >appearance>menus etc. Well, last night I did it that way but but there are no little arrows pointing down every time you have a submenu. And yes, drop down menu is enabled. So what am I doing wrong? Sorry for long explanation. Lacking technical lingo per say.

Share this post


Link to post
Share on other sites
kastelic
From looking at your site it appears to be working fine. Dropdowns are working and when I click on "Whats New" I go to the "whats new" category page. You said: "However, whenever I wanted to open a new page/blog or anything after clicking on any of the submenus or child pages, I would not get anywhere. " Its hard for me to understand the exact issue you are having at this point. Are you wanting that menu item to point to an actual "page" or the "category" that it is now pointing to?

Share this post


Link to post
Share on other sites
chisim11
My site amazingworldproperties.com does not have a "what's new", It may be a different site. I can point some of main navigation such as "property search" to link to another page, no problem but as indicated above unable to see the subnav. This was looked by rangelone and apparently forwarded to some developers? http://www.pagelines.com/forum/discussion/comment/71546#Comment_71546

Share this post


Link to post
Share on other sites
kastelic
Can we see a screen shot of your Appearance-> Menus admin page? Are you sure you have your custom menu set as the "Primary Menu" on that page?

Share this post


Link to post
Share on other sites
chisim11
Not sure how to post the screen shot in here, but the menu which I named "Main Nav" is under "Primary Website Navigation", under Theme Locations. Right underneath there is >Page Navigation in Folder Columns and > Page Navigation in Simple Footer Section but these are empty The "automatically add new top-level pages" box is not checked.

Share this post


Link to post
Share on other sites
catrina
Is the submenu supposed to show underneath primary navigation on the home page? Do you want the "Properties Search" to show a submenu? If it's a link to an external site, it can't have a submenu because it doesn't lead to a page within the WordPress install.

Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
chisim11
Yes, i understand that. Very odd. I just realize the submenus are actually showing up but only after clicking on them. When I originally created the main nav via page attributes(whether this was the wrong way or not), the submenus will appear everytime I would hover over the tabs. Also the submenus will appear in a sort of a column. Now the appear horizontally. Not sure why they dont appear after hovering over them and not sure why they are appearing horizontally. To be honest, not sue if I like the submenu vertically or horizontally. . Who knows??? Most of the tabs on the main nav are going to have submenus with the exception of blog and contact as a link will be used for these two. So I wanted to be able to click on one of the international properties, for instance, and then it will take me to a customized page(i guess that's what's called) and have a blog, pictures, etc. ..you know information about the property. Or for any other submenu. Now, I also see the submenus appear way to the left not aligned with the main nav and the 5 feature default boxes are also way to the left. I don't know anymore. This was supposed to be an easy and simple thing to do. What am I doing wrong. Please help!

Share this post


Link to post
Share on other sites
chisim11
Oh, one last thing. One google chrome the site looks decent. on firefox the logo on the bottom right looks faded. And forget about internet explorer. The main menu wrap around and the logos on the footer are one up, one down. what to do to have all these browser look the same. Or is it not possible?

Share this post


Link to post
Share on other sites
catrina
By default, the submenu is supposed to show only AFTER a parent page link in the menu is clicked on. This is the submenu that contains child pages for that parent page. It's normal for the submenu to appear vertical IF you enabled the drop down setting for the menu in your settings. It's only supposed to show up as horizontal if it's showing up as a submenu that's set to appear after you click on the parent link that includes subpages. Which one do you prefer? A menu that shows submenus when hovering over the parent pages or a menu that shows the submenu for a parent page only after clicking on that parent page? If the appearance of the sections on your site is messy, perhaps it is a CSS issue. Can you please paste all custom CSS you have at the moment?

Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
chisim11
While I'm still reading your explanation......Here's all I have for CSS body{} #cred {display:none} body div.branding_wrap {text-align: center;} ul#sub-menu li.menu-item {text-transform: lowercase;} #nav_row.main_nav, ul.sf-menu ul li {border-bottom: 0;} #featurenav {background-color: #000000;} #feature-footer {background-color: #000000; border: 0;} #feature-footer .feature-footer-pad {border:0; padding:0; margin-left: 4px;}

Share this post


Link to post
Share on other sites
chisim11
Your question: Which one do you prefer? A menu that shows submenus when hovering over the parent pages or a menu that shows the submenu for a parent page only after clicking on that parent page? I prefer the option of seen the submenu after hovering over. Otherwise, people may miss them. It is an easier way of navigation thru the page. I think. For instance: viewsoflajolla.com So how can I fix this?

Share this post


Link to post
Share on other sites
Rob
I think this would require some coding by a pro. Most menus are intended to simply appear on hover and allow the visitor to view while hovering. Candidly, I've never been a fan of this as it usually means the visitor has to move darn quick or the menu vanishes. This frustrates visitors. Have you considered one of our Pros for your solutions?

Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
chisim11
I got it to work the navigation now. I just need to be able to add a category page/blog, etc after clicking on a subnavigation. I have not been able to figure it out.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×