Jump to content
Sign in to follow this  
vindicus

PHP Issues WIth Feature Slide

Recommended Posts

vindicus

So I'm currently using a Modified Feature Page Template. It's working perfectly fine, except the THUMBNAILS beneath doesn't show at all. They do work when I use the original Feature template, so nothing wrong there. www.on-hands.com is the site. this is the code I'm using <?php global $pagelines_ID; if(is_page_template('page-fullwidth.php') || is_page_template('page-fullhighlight.php') || is_page_template('page-carousel-full')) $full_width_page = true; else $full_width_page = false; if(is_page_template('page-carousel.php') || is_page_template('page-carousel-full.php')) $carousel_page = true; else $carousel_page = false; if(VPRO && (is_page_template('page-feature.php') || is_page_template('page-feature-page.php') || (is_home() && pagelines('featureblog')))) $featureslide_template = true; else $featureslide_template = false; if(VPRO && (is_page_template('page-feature.php') || m_pagelines('featureboxes', $pagelines_ID))) $fboxes_template = true; else $fboxes_template = false; if(VPRO && (is_page_template('page-frontpage.php') || is_page_template('page-feature-page.php') || (is_home() && pagelines('featureblog')))) $featureslide_template = true; else $featureslide_template = false; if(VPRO && (is_page_template('page-frontpage.php') || m_pagelines('featureboxes', $pagelines_ID))) $fboxes_template = true; else $fboxes_template = false; ?> <?php if($featureslide_template) get_template_part('pro/template_feature'); ?> <?php if($carousel_page) get_template_part('pro/template_carousel');?>

<?php if(!is_page_template('page-highlight.php') && !is_404()) get_template_part('library/_sub_head');?> <?php if(is_page_template('page-fullhighlight.php')) get_template_part ('pro/template_highlight'); ?> <?php if($fboxes_template) get_template_part('pro/template_fboxes');?>
<?php if(is_page_template('page-highlight.php')):?> <?php get_template_part('pro/template_highlight');?> <?php get_template_part('library/_sub_head');?> <?php endif;?>
<?php get_template_part ('library/_contentfooter'); ?>
What's wrong with my code? Why won't the thumbnails show?

Share this post


Link to post
Share on other sites
vindicus

My fault. The slider is fine, but in my hunt for a frontpage without content and sidebar, I had to make a new template, including the feature slider. Everything is fine, except that the thumbnails beneath (showing the different slides) went missing in my new template. And I cant find the reason :(

Share this post


Link to post
Share on other sites
catrina

I think you could use the default feature slider without making changes and use CSS to hide and the content and sidebar on only the front page.


Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
vindicus

I'll do whatever works. Donyou know any css codes that mighpt help me therre, and hoe do I apply them only to the frontpage?

Share this post


Link to post
Share on other sites
catrina

You can change your feature slider back to the default. Once you've done that, let me know and I'll check your site out and give you sample CSS to use.


Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
catrina

Please add the following CSS to Custom Code > CSS Rules:

body.home #maincontent {display: none;}
	body.home #sidebar {display: none;}
	body.home div.post-footer {display: none;}


Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
vindicus

Omg. I cant belivie this.. I really can't! I spent over 4 hours yesterday trying to solve this problem, and here you come working your magic fingers applying a short simple css code that fixes it all.. I hate and love you at the same time! Mostly love though.. Thanks!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×