Jump to content
Sign in to follow this  
WebIT

Nav Pulldowns show 2 colors grey and blue. should be blue only.

Recommended Posts

WebIT

Yes: See bottom. Looks like we addressed this before. /* Formidable CSS */ #frm_field_585_container textarea[disabled], #frm_field_585_container textarea[readonly]{opacity:1;filter:alpha(opacity=100);} /* Paw BG */ body { background: #F7F7F7 url(http://www.capek9cardio.com/wp-content/uploads/2010/09/twopawprints-bw.jpg); background-repeat: repeat; background-attachment:fixed; } /* Footer Border */ #footer .content {background:#ffffff; border:1px solid #AAA;} /* Login and Social Icons */ #loginzone, #loginzone ul, #loginzone li, #loginzone a{display:inline; margin:0px; padding:0px; font-size:15px} #loginzone{float:right} .icons { position:absolute; /* left:0px; */ right:0px; bottom:0px; height: 50px; } /* Remove horizontal line between fboxes */ .page-id-1829 .fboxes.boxcount_3{display: none} .page-id-14 .fboxes.boxcount_3{display: none} .page-id-3684 .fboxes.boxcount_3{display: none} .page-id-3103 .fboxes.boxcount_3{display: none} /* Submit Button */ .with_frm_style p.submit{background:none; border:none; color:none;padding:2px 0;} /* Post Hide Meta */ .category-dog-walking .metabar, .category-books .post-footer{display:none} .category-dog-running .metabar, .category-books .post-footer{display:none} .category-pet-sitting .metabar, .category-books .post-footer{display:none} .nocomments {display:none; } /* Formidable CSS */ #frm_field_585_container textarea[disabled], #frm_field_585_container textarea[readonly]{opacity:1;filter:alpha(opacity=100);} #frm_field_591_container textarea[disabled], #frm_field_591_container textarea[readonly]{opacity:1;filter:alpha(opacity=100);} .with_frm_style .ui-datepicker-next{text-align:inherit;} /* e-shop remove bullets category view */ .wpsc_categories ul { list-style-type:none; } /* remove footer credit link #cred {display:none;} */ /* remove gray nav bar */ .current-menu-item a{background-image:url("/wp-content/themes/iblogpro/pro/images/nav-sprite-blue.png") !important;}

Share this post


Link to post
Share on other sites
catrina

Please add the following CSS to Custom Code > CSS Rules:

ul#menu-top li#menu-item-3171, ul#menu-top li#menu-item-3948 {background-color: #072340;}


Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
WebIT

I added this custom code and the nav pulldown is still showing grey not blue.

Share this post


Link to post
Share on other sites
Kate

The gray is what you currently have set for your menu background color. So, you can solve the issue one of two ways: 1) Changing the bg from gray to the shade of blue you have for the nav items. 2) Adding this code:

#nav ul li .sub-menu a{
	    background: blue !important;
	}

NOTE: The "blue" should be replaced with either the hex value of the blue you're using, or with the URL to the image (which would require slightly different syntax).

Share this post


Link to post
Share on other sites
WebIT

iBlog Pro offers 3 default colors: Grey, Blue and Black. I want the stock blue. When I add your code I loose the highlight colors. Please take a look. www.capek9cardio.com

Share this post


Link to post
Share on other sites
WebIT

Tried your code: #nav ul li .sub-menu a{ background: blue !important; } gave me a solid bg Tried my old code: } .current-menu-item a{background-image:url("/wp-content/themes/iblogpro/pro/images/nav-sprite-blue.png") !important;} gave me grey and blue Tried to link iBlog sprite (current code): #nav ul li .sub-menu a{background-image:url("/wp-content/themes/iblogpro/pro/images/nav-sprite-blue.png") !important;} No highlight (but blue) and some grey on bottom of pulldowns

Share this post


Link to post
Share on other sites
kastelic

Where are you putting your custom CSS? Can you remove all the custom CSS that is affecting your nav bar?

Share this post


Link to post
Share on other sites
WebIT

Theme options > custom code. www.capek9cardio.com Here is what I had (now removed): /* remove gray nav bar */ #nav ul li .sub-menu a{background-image:url("/wp-content/themes/iblogpro/pro/images/nav-sprite-blue.png") !important;}

Share this post


Link to post
Share on other sites
catrina
Can you enable the black color scheme so that we can see if the grey bar shows up (that way, we know if it's a problem with the blue theme)?

Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
WebIT
i removed custom css and changed to black theme and YES.. problem exists on all colors. good observation. now what?

Share this post


Link to post
Share on other sites
kastelic
Sorry, for the runaround, can you please enable the blue theme? You just want the regular blue color scheme right, nothing special? But for some reason its not showing correctly when you enable it?

Share this post


Link to post
Share on other sites
WebIT
correct. blue. now enabled.

Share this post


Link to post
Share on other sites
catrina
Hmmm. It looks like that shade of grey is created with this hex code: #363636. Can you find any instance of #363636 in your CSS files and if it's anywhere, can you provide the name(s) of the CSS file(s)?

Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
WebIT
Is there someone who knows this theme that can help me please?

Share this post


Link to post
Share on other sites
Kate
Hello, I understand your frustration. But, please know that we're all moderators, quite familiar with the themes, and just trying to help you out ;) Now, about the issue: turns out it seems to be being caused by a cached CSS file from the wp-minify plugin (stored in wp-minify/cache/). It's turning the background of .sub-menu to gray (the default of iBlogPro). You could either a) disable the plugin, or b) add this line of code in your css: [code]#wrapper #nav ul.dropdown ul.sub-menu{background:#072340 !important;}[/code]

Share this post


Link to post
Share on other sites
WebIT
Awesome. That worked. I appreciate all of your work. The only problem now is there is no hover color. Thanks, Jason

Share this post


Link to post
Share on other sites
ikonics
So the gray is coming from a background image. If you do this: [code]#wrapper #nav ul.dropdown ul { background-image:none !important; }[/code] That should take care of the gray. I tested it out it firebug on your site and it worked for me. To get a hover effect, you need to use the :hover pseudo selector. You could try: [code]#wrapper #nav ul.dropdown ul li:hover { background:YOURCOLOR !important; }[/code] Whether or not the "!important" is necessary... idk. If you use it, and it effects other elements on your page drop it off and try without. These selectors seem specific enough without but, sometimes with pagelines themes it's just easier to use it than to hunt through the css. Hope that helps.

Share this post


Link to post
Share on other sites
WebIT
good code. the hover only worked when I have 2 sub menus though (see new clients > complete your paperwork pulldown)

Share this post


Link to post
Share on other sites
catrina
Please try the following code for the hover: [code]#wrapper #nav ul#menu-top ul#sub-menu li:hover { background:YOURCOLOR !important; }[/code]

Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
WebIT
I added that code.. Did it work? I'm on an iPad and can't check. Perhaps I should remove the other hover code above it.

Share this post


Link to post
Share on other sites
WebIT
I commented out this old code #wrapper #nav ul.dropdown ul li:hover { background:#0099ff !important; } Not sure it worked.

Share this post


Link to post
Share on other sites
kastelic
Really close on that last one. Just tested this to work 100%: [code] #nav ul.dropdown ul li:hover a { background: #09F !important; } [/code]

Share this post


Link to post
Share on other sites
WebIT
Wow you rock! Ok kastelic, just one last tweak and I'll put this to rest. 2 menu's deep entire drop down panel is the highlight color: www.capek9cardio.com >new clients >>complete your paperwork

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×