Jump to content
Sign in to follow this  
kstei

Layout Width setting Ignored by Platform?

Recommended Posts

kstei

- In the Layout Editor, I have the page width for a full-width page set to 1200px. - I have the Home Page layout mode set to use the full-width layout For some reason, Platform seems to still try to impose the 960px limit on that page. Any ideas on how I can fix this? http://www.survivalnotes.org For comparison, the Table of Contents is set to be 1050px wide.

Share this post


Link to post
Share on other sites
catrina

You can trying using custom CSS to change the width. Is it only the full-width layout that you want to adjust?


Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
kstei

So, there is apparently a problem with dynamic.css on my installation - it's not updating when I make changes to the Platform admin UI. I can go in and change dynamic.css manually and it works.

Share this post


Link to post
Share on other sites
michaeljohnprice

I'm having the same problem. I installed the child theme and the dynamic.css in the platformpro is overriding my settings. The only way I can adjust it is in the custom css section, which defeats the purpose of using the child theme. No matter what I set the global content layout to the, page always 20px larger than my global content. This worked until I started using the child theme to preserve my customizations as recommended. If anyone has solved this, I'm currently working through it now. Thanks :)

Share this post


Link to post
Share on other sites
michaeljohnprice

Of course, I figured out the css right after I posted this... I put this css in the style.css of the PlatformBase and that solved the issue. #site.one-sidebar-right #page, #site.one-sidebar-right #footer, #site.one-sidebar-right #page-canvas { width: 1072px; } It didn't work in the PlatformBase when I uses this standard styling: fixed_width #page, .fixed_width #footer, .canvas #page-canvas { width: 1072px; } Maybe there was an easier way.

Share this post


Link to post
Share on other sites
michaeljohnprice

Definitely download Firebug at http://getfirebug.com if you haven't already, which will usually help you resolve the issue. I've often found that to customize the css, you often have to look at the resulting html of the page AND the CSS because the html will include ids and classes that inherit styling. If you go to the root id or class, you can often override the dynamic.css.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×