Jump to content
Sign in to follow this  
aiiiiit

has_cap-error

Recommended Posts

aiiiiit

Hi! I've tried to change users rolls to author, but when they login, they just see blank pages with a menu. I ran define('WP_DEBUG', true); and got the error: Notice: has_cap was called with an argument that is deprecated since version 2.0! Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead. How can I fix this?

Share this post


Link to post
Share on other sites
catrina

Which version of PlatformPro are you using? Did you try changing user roles in the "Users" section of your Dashboard or by another means?


Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
aiiiiit

catrina: PlatformPro 1.2.2. Yes, I used the "Users"-section to change the roles.

Share this post


Link to post
Share on other sites
Simon

You should upgrade, The latest version definitely has no capabilities problem.

Share this post


Link to post
Share on other sites
aiiiiit

Pross: How can I easily upgrade, without losing my design?

Share this post


Link to post
Share on other sites
Simon

Have you edited the actual theme files?

Share this post


Link to post
Share on other sites
aiiiiit

pross: No, I've just used the settings. I've maybe editted smal stuffs in some files, but nothing very important I think...

Share this post


Link to post
Share on other sites
Simon

OK considering the version difference, upgrade isn't going to be easy! 1st, im assuming you already have updated wordpress and all your plugins? Heres how i would do it: Get a full site backup ( easy in cpanel other hosting panels may differ ). Then get a mysql backup. This gives you the option to rollback your entire site, or just the database. Go to platform settings and download the settings file. Now, switch theme to twentyten. Install latest platformbase. rename platformpro to platform_bak ( DO NOT DELETE IT YET ) install platformpro latest. Activate Platformbase theme. Go to options and click save. Hopefully things will be OK. Its probably not going to be 100% clear sailing as your quite a bit out of date. If it all goes wrong, you will have rollback options available if you did those backups!

Share this post


Link to post
Share on other sites
aiiiiit

pross: It wasn't that easy... Probably I had editted more in the theme than I thought... I think I need help. I'm going to restore the site.

Share this post


Link to post
Share on other sites
Simon

I suggest setting up a dev site, on your PC, mirror the site exactly. Using XAMPP(win) or MAMP(osx) setup your hosts file to 'spoof' you dns so your PC when loading the sites url will actually run it locally. No need to change any urls in the db or setting then ;)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×