Jump to content
Sign in to follow this  
platinum

Footer appearing different on one page only

Recommended Posts

platinum

Hi all, I am using Platform Pro, version 1.5.2 with wordpress 3.2.1. - Site Design Mode: Full-width design with canvas This has me baffled... ... I am using the following css to modify the footer on my site http://www.knuckle.co.nz

	.fullwidth #footer {
	width:984px;
	position: relative;
	margin-left:auto;
	margin-right:auto;
	background-image: -webkit-gradient(
	    linear,
	    left bottom,
	    left top,
	    color-stop(0, rgb(2,32,122)),
	    color-stop(0.8, rgb(192,0,0))
	);
	background-image: -moz-linear-gradient(
	    center bottom,
	    rgb(2,32,122) 0%,
	    rgb(192,0,0) 80%
	);
	}
	

The problem is that ONLY on the contact page the css isn't modifying the footer (like it modifies the footer on ALL other pages of my site). Does anyone know what is causing this and how I may fix it? Any help is much appreciated, cheers.

Share this post


Link to post
Share on other sites
catrina

The footer in the Contact page requires a different CSS selector. Add this CSS instead:

.fullwidth #footer, #footer ul#list_fullwidth_sidebar {
	width:984px;
	position: relative;
	margin-left:auto;
	margin-right:auto;
	background-image: -webkit-gradient(
	linear,
	left bottom,
	left top,
	color-stop(0, rgb(2,32,122)),
	color-stop(0.8, rgb(192,0,0))
	);
	background-image: -moz-linear-gradient(
	center bottom,
	rgb(2,32,122) 0%,
	rgb(192,0,0) 80%
	);
	}


Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
platinum

Hi Catrina, Thanks for your reply. I have replaced the css with that which you recommend trying. The new css selector

#footer ul#list_fullwidth_sidebar

adds the footer on the contact page but its alignment is messed up and, it's also now messing up with the gradient and the footers on the other pages, please take a look at my site to see what I mean. You did say

The footer in the Contact page requires a different CSS selector
- can you briefly explain why I need a different css selector for the contact page? After all, it's just another page on my site, only with the name "contact-us" as opposed to something else like "about-us". I don't understand why that would make any difference. Thanks again, Luke

Share this post


Link to post
Share on other sites
Kate

Hey Luke, It really shouldn't matter which page. However, usually this happens when there's a markup issue above the footer. Did you try running the site through an HTML validator to make sure there weren't any errors? It could be in the contact form. Perhaps try taking that out and seeing if the problem persists. (I'd recommend rewinding before Catrina's changes to do that.)

Share this post


Link to post
Share on other sites
platinum

Hi Kate, Thanks for your comments. Here's what I have done... 1) Reverted back to the original footer css in my first post. 2) Checked the HTML on the contact page 3) Removed the "text" widget from the primary sidebar the contact page 3) Removed all other custom css except for the css as mentioned in 1) above. And it's still not working....HOWEVER... I have just realised that only on the contact page in the "PageLines Meta Settings" under "General Page Setup" I am using "one side bar on right" and was adding the address on the contact page using a "text widget" in the "primary sidebar". So, I changed the "PageLines Meta Settings" under "General Page Setup" back to -SELECT- and the problem has gone away. I am using a column plugin which gets the address on the right - done by just adding the columns shortcode when editing the page... So I have managed to use another method to fix this which is cool, BUT, I am still interested to know why the problem was occuring in the first place. If someone could shed some light it would be helpful and appreciated. Cheers, Luke

Share this post


Link to post
Share on other sites
Kate

Hey Luke, What was the markup you had in the text widget? Could be an error in there...

Share this post


Link to post
Share on other sites
platinum

Hi Kate, There was just a few lines of text in the text widget, could that be the problem?

Share this post


Link to post
Share on other sites
platinum

The contents gone now, as I have found an alternate method of achieving what I wanted per the information in my previous posts. All that I had previously in the text widget was text, no code whatsoever. I still can't understand why it wasn't working before though. It's not really a big deal, I just thought that someone with a bit more knowledge might be able to look into it fairly quickly and confirm whether there is an issue with Platform Pro or if it's just me.

Share this post


Link to post
Share on other sites
platinum

mmm, well... I have just had a look at the site now and the footer on the homepage now has a white space below it! So, the homepage now has a different footer from the other pages, it would be nice to know what is going on here. Any help would be great, thank you

Share this post


Link to post
Share on other sites
catrina

Hm, you can try increasing the bottom margin of it by adding this CSS:

#footer #fullwidth_sidebar {height: 50px;}


Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
platinum

Update... it was a plugin that was causing the issues. Thanks to everyone for your input :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×