Jump to content
Sign in to follow this  
jibfu

Specifying rotating image in header

Recommended Posts

jibfu

I can specify a single image header in the Global Options/Upload custom image dialog, but I'm trying to get a different image for a header according to which page is being displayed, and don't know where I can specify this information. Can someone help?

Share this post


Link to post
Share on other sites
catrina

CSS can be used to determine which image will display in which page. Can you please post a link to your site?


Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
jibfu

Link to the site: http://alttpro.com/ I'd like each of the nav items to have their own image that replaces the blue header image for that page only.

Share this post


Link to post
Share on other sites
jibfu

FYI - I also have base child installed.

Share this post


Link to post
Share on other sites
joie

Probably try something like this in your Custom CSS section for example for page ALLTPro Advantages (page id = 48) body.page-id-48#branding { background: url('http://alttpro.com/wp-content/uploads/2011/07/top_logo2.jpg'); background-repeat: no-repeat; } For me at global options upload logo, i upload a transparent logo and control the header image background from custom CSS

Share this post


Link to post
Share on other sites
jibfu

The Custom Code section in the Platform/Pro Settings interface? I placed code there, after uploading a transparent logo for the header, but so far, no dice.

Share this post


Link to post
Share on other sites
catrina

Here is revised CSS (spacing makes a huge difference):

body.page-id-48 #branding {
	background: url('http://alttpro.com/wp-content/uploads/2011/07/top_logo2.jpg');
	background-repeat: no-repeat;}


Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
jibfu

and the custom code section is where to place this?

Share this post


Link to post
Share on other sites
kgstew

Check to see that your image URL is correct. When I try to view the image it give me a 404.

Share this post


Link to post
Share on other sites
jibfu

It's always something simple, isn't it? All fixed. Thanks, all for your help!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×