Jump to content
Sign in to follow this  
anjalijindal

Changed URL in Wordpress, Now 404 Error

Recommended Posts

anjalijindal

Hello! I'm freaking out. I have my site hosted on bluehost.com. The domain I have hosted in www.chakshoothefilm.com. The website I am working on in Pagelines is www.chakshoothefilm.com/blog. It is being redirected from www.chakshoothefilm.com because it was replacing an old website. I went in to Settings in wordpress and changed it from www.chakshoothefilm.com/blog to www.chakshoothefilm.com and now I can't access either one. Whenever I try a 404 Error shows up instead. I have no idea why I changed it in wordpress...but I did it anyway. Any ideas? I hope it's not lost forever.... Thank you.

Share this post


Link to post
Share on other sites
bonngean

This isn't a Pagelines error, it's something that needs to be handled by your web host. Contact Support for your website (who you host it from) and ask them for assistance. You'll get personal service there with less down time rather than waiting for an answer here. --Bonnie

Share this post


Link to post
Share on other sites
catrina

Let us know what the host says and if there's anything WordPress-related we can fix.


Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
anjalijindal

Ok I will try them and let you know. Thanks.

Share this post


Link to post
Share on other sites
kastelic

If you login to your hosting backend and open PHPmyAdmin and then open your wordpress database you can manually change this value. There are two locations which list the URL for your site, both it the WP-Options table. Switch them back to what you had before. Another way to get it back is to add a couple lines to your wp-config.php file to manually override the URL stored in the database: define('WP_HOME','http://example.com''>http://example.com'); define('WP_SITEURL','http://example.com''>http://example.com');

Share this post


Link to post
Share on other sites
anjalijindal

you're literally a genius. this worked. thanks so much! i'll stop freaking out now. EDIT: Ok it mostly worked. It seems that the home page comes up, but not any of the other pages. Is this something I also have to change in bluehost?

Share this post


Link to post
Share on other sites
catrina

Hm, I don't think there was anything else that needed to be changed in bluehost. Did you adjust the permalink structure settings at all in WordPress?


Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
anjalijindal

I just added the two lines as well that Jimmy mentioned but that didn't work. I didn't adjust anything in wordpress either...

Share this post


Link to post
Share on other sites
Kate

Anjali, Are you able to access the dashboard? If so, could you paste a screenshot of the Settings->General page?

Share this post


Link to post
Share on other sites
anjalijindal
J5TmA.jpg Here you go - is this what you need?

Share this post


Link to post
Share on other sites
Simon

Change your permalinks to default and delete the file `.htaccess` in your blog folder. You will need to enable view hidden files to see it.

Share this post


Link to post
Share on other sites
slingr

I have similar but different problem. I 'volunteered' to move my daughter's blog from the /wordpress sub-directory to the root so that her blog page would become her home page at www.herurl.com. I think I induced a problem because although it seemed to work at first, now www.herurl.com returns the web host provider static page saying that the domain name hasn't propagated yet. Her admin panel IS accessible at www.herurl.com/wp-admin, and once inside everything appears correct - EXCEPT the home page can't be accessed, the same error static page is returned. In General | Settings, both site url field are set to www.herurl.com . I think I may have an htaccess problem because after I completed the move the other night, I changed her permalinks from the default to one of the custom options. At the time, I didn't notice that at the bottom of the page, WP tried to tell me that it couldn't write to the htaccess file and gave me the code to use. I just noticed this an hour ago and modified .htaccess to the following, per the WP message: # BEGIN WordPress RewriteEngine On RewriteBase /wordpress/ RewriteRule ^index.php$ - [L] RewriteCond %{REQUEST_FILENAME} !-f RewriteCond %{REQUEST_FILENAME} !-d RewriteRule . /wordpress/index.php [L] # END WordPress Can anyone tell me if this looks to be correct for a Wordpress installation that was previously in the /wordpress sub-directory, but now resides in the root, with a custom permalink? BTW, I tried changing the permalink default and then deleting the .htaccess file, but it didn't resolve the home page url issue and none of the existing posts and pages would preview in WP. Thanks.

Share this post


Link to post
Share on other sites
slingr

Disregard previous comment. My webhost provider helped troubleshoot the problem.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×