Jump to content
Sign in to follow this  
kellid

Excerpt and Full post page

Recommended Posts

kellid

Hopefully this is the last time I need to bug you guys with a problem I'm having. I have excerpts set up on my blog page. I have the "continue reading" or title linking to a single post page but that also has only an excerpt. I would like the the main blog page to show posts with excerpts but single post pages to show Full content. I think I need to edit the postloop.php around... <div class="post-excerpt"><?php the_excerpt(); ?></div> <?php if(pagelines_is_posts_page() && !pagelines_show_content( $post->ID )): // 'Continue Reading' link echo get_continue_reading_link($post->ID); endif; pagelines_register_hook( 'pagelines_after_excerpt', 'theloop' ); // Hook ?> <?php endif; ?> </div> </div> <?php endif;?> <?php if(pagelines_show_content( get_the_ID() )): // Post and Page Content ?> <div class="entry_wrap fix"> <?php pagelines_register_hook( 'pagelines_loop_before_post_content', 'theloop' ); // Hook ?> <div class="entry_content"> <?php the_excerpt(); ?> <div class="clear"></div> <?php // Content pagination if( is_single() || is_page() ) wp_link_pages(array('before'=> __('<p class="content-pagination"><span class="cp-desc">pages:</span>', 'pagelines'), 'after' => '</p>', 'pagelink' => '<span class="cp-num">%</span>')); // Edit Link $edit_type = (is_page()) ? __('Edit Page','pagelines') : __('Edit Post','pagelines'); edit_post_link( '['.$edit_type.']', '', ''); pagelines_register_hook( 'pagelines_loop_after_post_content', 'theloop' ); // Hook ?> I've tried to make a few changes but get error messages. Can you please lead me in the right direction? thank you :)

Share this post


Link to post
Share on other sites
catrina

You need to disable the excerpts in your single post pages by going to Settings > Blog And Posts. Uncheck the box next to Single Post Pages under Post Excerpt Placement.


Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
kellid

hi catrina, i can see you work hard...always responding! unfortunately i already did that. i wonder if it's because i have an excerpt plug in installed to allow my images to show in the excerpt? maybe i'll try to uninstall that plug in and see what happens.

Share this post


Link to post
Share on other sites
kellid

this is so aggravating. i uninstalled excerpt editor and changed the < ?php the_excerpt(); ?> back to < ?php the_content(); ?> to start from square one. i reinstalled the excerpt editor but it would only work if i changed the coding above back. do you know what it is i'm going wrong? there has to be a way to have excerpts on the blog page and full content on single page. should i provide a link so you can look closer? thanks again for the feedback. k

Share this post


Link to post
Share on other sites
catrina

There is a way, but it looks like there's another problem with something. Can you try deactivating your plugins one by one first so we can eliminate the possibility of a plugin conflict?


Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
kellid

only the plugins pertaining to the excerpt correct? done. should i also change the coding in the post loop back to the original?

Share this post


Link to post
Share on other sites
catrina

All plugins including the ones not related to the excerpt should be deactivated. Also, you should change the coding back to the original. Once you've done, make sure the excerpts are disabled in Single Post Pages in Settings > Blog And Posts.


Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
kellid

I've deactivate all plug ins and the coding is back to the original.

Share this post


Link to post
Share on other sites
kellid

Yes, The excerpt it showing up twice on the blog page but I now have a full post on the single page. progress!! any idea how to get rid of the double excerpt??

Share this post


Link to post
Share on other sites
catrina

The "Continue Reading" link is appearing twice, but I don't see the excerpt being doubled... or maybe I'm just seeing it wrong. Are those two paragraphs one excerpt? Or is one of them an excerpt and the other some other paragraph?


Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
kellid

I added those links when i was using the excerpt editor. I deleted the plugins so not sure but i will try to addthe plug in again and see if i can take it out that way. I'll try to figure it out from here. YOU ARE EXCELLENT CATRINA!!! thank you so much for taking the time. much appreciated!!! k

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×