Jump to content
Sign in to follow this  
strategicblend

Featured Image disappears on pages

Recommended Posts

strategicblend

For some reason, Platform Pro disables and/or hides the "featured image" box on all pages. I already checked the screen options, and it doesn't even appear there as being clickble. Why does this happen?

Share this post


Link to post
Share on other sites
catrina

If you're looking at the page editor where pages are created/edited, there is no featured image box by default (this is a WordPress thing). Featured images are only allowed for posts.


Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
strategicblend

Catrina that's not true. WP includes the featured image widget on all pages too - Platform Pro removes it for some reason.

Share this post


Link to post
Share on other sites
catrina

When I activate other themes to check, the featured image setting isn't there either. These are PageLines themes, though. I'm not sure why this is and I've never even noticed before! Huh. I'm not certain whether this is intentional or not, but I'll ask.


Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
strategicblend

Anyone have any update or ideas on this? Hoping to hear from the theme devs themselves.

Share this post


Link to post
Share on other sites
strategicblend

That answer only addresses the multi-site setup. It does not apply to a single site, as I don't have the Network admin option. Is there a solution for single-site?

Share this post


Link to post
Share on other sites
Kate

Honestly, I'm not 100% sure why it's only for pages. But, you can read more about the differences here: http://markjaquith.wordpress.com/2009/12/23/new-in-wordpress-2-9-post-thumbnail-images/ In your functions.php file, you can try adding this line (to the bottom):

add_theme_support( 'post-thumbnails', array( 'page' ) );

Make sure that's the functions.php file in your Base theme.

Share this post


Link to post
Share on other sites
strategicblend

The issue is that the theme itself is built to hide featured images. I need one of the theme developers, or someone in the know, to explain why this is happening. It's a major bug/conflict.

Share this post


Link to post
Share on other sites
Kate

As I mentioned, I don't know for the time being why this is the case. I'll definitely bring it to the developers attention. But, if you're looking to use featured images on pages, then please do try the suggestion ;)

Share this post


Link to post
Share on other sites
sanderpinkse

Some months ago, I wrestled with the same problem. At the time, I did exactly what Kate suggested here, and it worked fine. However, since the latest PlatformPro update, the featured image option has disappeared from the backend again. Existing featured images continue to work, but there is no way of adding a new one. Is the syntax: add_theme_support( 'post-thumbnails', array('post', 'page') ); still valid? And if so, what's changed in PlatformPro?

Share this post


Link to post
Share on other sites
Simon

Yes that code is still valid, nothing has changed in regards to featured image.

Share this post


Link to post
Share on other sites
sanderpinkse

Well, something has changed. They stopped working... ;-) Any idea what could be going on? Maybe the combination of WordPress 3.2 and PlatformPro has got something to do with it. Apart form the WordPress and the Platform Pro upgrades, nothing else has changed on my end.

Share this post


Link to post
Share on other sites
sanderpinkse

I did some more testing. When I add a custom post type to add_theme_support( 'post-thumbnails', apply_filters( 'pagelines_post-thumbnails', array('post') ) ); in PlatformPro (via /includes/core.init.php), it works fine. When I add it to funtions.php in PlatformBase, no dice. What can be the matter? As I said, this just to work fine before.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×