Jump to content
Sign in to follow this  
jenmarlin

Archives for categories and tags don't show up

Recommended Posts

jenmarlin

Hi there! This is a stupid question, but here we go: When I click on a certain tag or category on my website (Platform Pro) I just get the start/home page, and not the posts in that category or with that tag. I realise I must have missed something somewhere (or accidentally hidden the archives), but I can't figure out where? I guess there are also different ways to display those archives, but for now I'm actually happy just to have them show up at all! =)

Share this post


Link to post
Share on other sites
jenmarlin

Do you mean for permalinks? I haven't made any changes for the URL (http://mariasoxbo.se) or the permalinks (/%postname%/). What else can cause this?

Share this post


Link to post
Share on other sites
Rob

Jen, when I clicked film, it works fine in Firefox. Could this be a problem of your browser?


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
jenmarlin

rangelone: That's beyond weird! I use Firefox and Chrome, and it doesn't work for me in either. I have even tried different computers! Hmm, what to do then? I just get tossed back to the homepage when ever I click on a category or a tag.

Share this post


Link to post
Share on other sites
jenmarlin

Sorry, but I still need help figuring out why it doesn't work for me (even though it works for others). I still get the home page every time I try a category or tag. I've tried three different browsers and to different computers (on different locations) so it can't really be a cache problem either. Any help is greatly appreciated!

Share this post


Link to post
Share on other sites
Rob

Jen, I just went back to your site in Firefox. My apologies. Actually, I used the menu, not the sidebar. Yes, it does bring you back to the homepage. You might need to go into that widget and check to see where the links are going. It appears they may not be directing to the right locations and may need to be customized.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
jenmarlin

Ah, ok - so the problem does exist. =) It's not an unusal widget, just the preinstalled category widget, and I haven't made any adjustments to it. And also, when you click at the tag under the post, the same (bad) thing happens. So I'm not sure it's the widget, but just to be sure ??“ how do I check where the links go?

Share this post


Link to post
Share on other sites
Rob

What appears to be your links should be listed in the Blogroll. On the left side of your Dashboard, there's a tab for "Links". That's where those links come from. Check your Categories (under Posts) to see where each category is going.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
jenmarlin

Hmm, I can't really see that under categories? All I can make out is that "Film" for example has "film" as permalink. I have other wordpress websites and this has never been a problem, it just sorts itself out automatically. I feel like there's a problem with how my website displays archives or search results. (Not at all, that is.) Is there a setting in Pagelines that should be checked or unchecked in order for one category to display, for example? (I'm happy to let someone in on the inside to help me out! If someone is willing to take a look, please send me an e-mail: maria@mariasoxbo.se).

Share this post


Link to post
Share on other sites
Rob

I am sorry Jen, I should have said "Check your Links to see where each is going".


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
jenmarlin

Sorry, I don't think I follow? The only thing I find under Links in the dashboard are linkes I manually put there, like my Twitter page and other urls not associated with my website. So, no links connected to my archive or categories are found there. And if I check the permalinks for what should have been my categories, like for example "film", it should be http://mariasoxbo.se/amne/film, and that just leads me to the homepage. Or am I checking the wrong thing? Sorry if I'm a bit slow in following your directions... Thank you for trying to help! But ??“ could the fact that I've changed the word "category" to "?¤mne" (Swedish word) have something to do with it?

Share this post


Link to post
Share on other sites
Rob

Possibly because of the "?¤" character. My apologies, I thought the links on the side was your blogroll. I don't speak/read Swedish.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
jenmarlin

Ah, I see - no, perhaps I've explained badly: My problem is that all the posts I do (the ones in the carousel on the start page) is tagged with a publication (for example Cosmopolitan) and a category (for example Film, same word in Swedish and English). But when I click either the tag Cosmopolitan (where I should get all Cosmopolitan-tagged posts as a result) or the category Film (where I should get all posts in the category), I only get the start page. Hence the headline of this thread: Archives for categories and tags don't show up. Perhaps the ?„ can explain something, however the permalink is amne without the dots. But since the same problem occurs regarding tags I believe something else is causing the problem. I do hope someone can help me sort this out, since I can't figure out what the problem is!

Share this post


Link to post
Share on other sites
Andrew
What's going on is it looks like you've edited your 'posts' page in Template Setup so that there aren't any posts? Did you set your homepage as a static page, (under wp > settings) ? All your category, tag, archive pages use the 'posts' template in drag drop....

Share this post


Link to post
Share on other sites
Jenny
Also, do you have any caching or redirection plugins enabled?

Jenny :: Web designer at Simple Mama (follow me at @simplemamacom)

Check out Share Me, a social sharing add-on for DMS that is super simple to set up.

Share this post


Link to post
Share on other sites
jenmarlin
arpowers: Ah, tell me more! I have WP in Swedish, so it's a bit difficult to follow instructions in English, but I'll give it a try! What exactly should I look for in the PlatformPro->Template setup? And WP-> Settings, where can I see whether I set up the homepage as static? simple_mama: No, not that I know of, I have very few plugins/widgets installed, and I can't see any other widgets that seem to have that function.

Share this post


Link to post
Share on other sites
Jenny
Static page can be checked here: Wordpress -> Settings -> Reading Make sure "content area" section is added here: Wordpress -> PlatformPro -> Template Setup -> Posts Pages (dropdown)

Jenny :: Web designer at Simple Mama (follow me at @simplemamacom)

Check out Share Me, a social sharing add-on for DMS that is super simple to set up.

Share this post


Link to post
Share on other sites
jenmarlin
Hi, sorry for the absence, I've been out of town for a while. simple_mama: I've checked the Wordpress->settings->Reading, and the "Your latest posts" (or whatever it might be called in the English version) is checked. It says 10 posts per page, and that the feed includes the whole posts. That's all the information I can find on the "Reading" page, so a "content area" seems to be missing? How do I actually add the post pages?

Share this post


Link to post
Share on other sites
Jenny
Do you have an actual page that you created to be your "home" page? If so, you will need to change that in Wordpress ->Settings -> Reading and select the radio button next to "a static page" then select your home page under the appropriate box (whether it is a page or a posts page, not both). To make sure you have a content area activated, go to Wordpress -> PlatformPro -> Template Setup -> Posts Pages (dropdown) and make sure "Content Area" is in the left side (i.e. activated).

Jenny :: Web designer at Simple Mama (follow me at @simplemamacom)

Check out Share Me, a social sharing add-on for DMS that is super simple to set up.

Share this post


Link to post
Share on other sites
jenmarlin
simple_mama: THANK YOU! The content area thing did the trick! If you scroll down now you can see the posts in the category Mode / Stil. Thank you! http://mariasoxbo.se/amne/mode-stil/ The "home page" thing though ??“ I haven't created a page to be my home page, and I guess I should, right? Ok, so here's what I can't figure out: * I want the home page to look like it does right now: http://mariasoxbo.se with the carousel and the call out section. (And I guess add a menu choice called "Home".) * However, I don't want the post pages to include the call out section, the way it does now. How do I create a home page that looks like the start page looks now, and how do I remove the callout section from the post pages without removing it from the home page? Sorry for all the questions, I LOVE pagelines, but it SO different from anything I worked with before so I'm having trouble grasping the functions... =)

Share this post


Link to post
Share on other sites
jenmarlin
Ah, another thing ??“ now the posts are visible on the start page http://mariasoxbo.se too, and I only want them to be shown when you click on one of the items in the carousel. How do I remove them from the home page?

Share this post


Link to post
Share on other sites
catrina
Do you have the callout section enabled in your footer in Template Setup? It can be hidden on post pages using CSS (the same goes for posts you want hidden on the home page).

Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×