Jump to content
Sign in to follow this  
c1burns

Blog post title text -> image (EcoPro)

Recommended Posts

c1burns    0
c1burns

Hi, all. I recently purchased the EcoPro theme, and like it quite a bit so far. I do have one question that I haven't been able to find an answer to in the docs or forums. In the theme demo (http://www.pagelines.com/demos/ecopro/blog/), the blog post titles are replaced (or covered) by images with the same text. So in the demo, the "The Beaches" plain text is replaced by an image with the same text. In my install, this is not happening (i.e., it's just plain text, no image). What do I need to do to make this happen? I've seen plug ins that can do this, but I want to see if 1) EcoPro should be doing it out of the box; or 2) if there was a specific plug in used in the demo that has been proven to work well with this theme.

Share this post


Link to post
Share on other sites
justme    0
justme

I must admit your post piqued my interest but I must be blind. I only see text, no images.

Share this post


Link to post
Share on other sites
Andrew    201
Andrew

EcoPro should actually do this out of the box... its related to the 'font replacement' options you see under theme options. If this is enabled, then you might be getting a JS conflict (we're using Cufon font replacement) Do you have Firebug installed? if so, are you seeing conflicts?

Share this post


Link to post
Share on other sites
c1burns    0
c1burns

Hi, Andrew. Appreciate the help. I checked that I have the option enabled, and I do. I then looked for JS errors with Firebug, and sure enough there were. I deactivated all of my other plug-ins so that I just had the base theme + content, and I kept getting an error for the museo.font.js file. The source looked like this:

		<!-- Font Replacement -->
	    		<!-- Font Replacement -->
	
		<script type="text/javascript" src="http://www.simplifyfood.com/wp-content/themes/EcoPro/core/js/cufon-yui.js" ></script>
				<script type="text/javascript" src="http://www.simplifyfood.com/wp-content/themes/Eco/js/Museo.font.js" ></script>
			<script type="text/javascript">
			Cufon.replace('.fcontent .fsub, .fcontent .ftitle, .fcontent .ftext p,  #highlight .fcontent', {textShadow: '#444 0px -1px'});
			Cufon.replace('.site-title, .pagetitle, a.featurelink', {hover: true, textShadow: '#444 0px -1px'});
						Cufon.replace('.site-description, .contentcontainer h1, .contentcontainer h2', {hover: true});
				</script>
	

For some reason, the theme is looking in /Eco instead of /EcoPro for this particular file. Only for this file and the favicon image is it doing this; the rest have /EcoPro in the path. I had installed the free Eco theme first for a test run, and then installed EcoPro. I can copy the museo.font.js file into the /Eco theme directory and it works, but I can't for the life of me figure out what is telling it to look in the other theme. The wp_options table has a value of "EcoPro" for template, and I haven't been able to find the root elsewhere in the database or php files. Any ideas on where I can find this setting? Thanks!

Share this post


Link to post
Share on other sites
Andrew    201
Andrew

strange error... I checked it out and haven't figured out why it would be doing that. Can you change the `Eco` to `EcoPro`? Does that fix your issues?

Share this post


Link to post
Share on other sites
c1burns    0
c1burns

I finally managed to track it down. The "Replacement Font File URL" option in the EcoPro -> Theme Options -> Text Options screen wasn't updated when I installed the new theme. I manually updated the path to the .js file and it's working now. Appreciate the help.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×