Jump to content
Sign in to follow this  
aemillerco

Upgrading - is it really that difficult?

Recommended Posts

aemillerco

Wow... I have been beating up on you guys for a long time because I thought there were no updates, no support, etc. BUT... I just realized that your theme doesn't give update alerts in the admin area! I am way out of date, but there is no easy upgrade option from the backend like every plugin, theme, and even the WP core. So I did a little research on upgrading and it looks like a nightmare! Ughh... What should i do? How come we cannot just click to upgrade like everything else in WP?

Share this post


Link to post
Share on other sites
bevj

upgrading is a breeze, as long as you install and use the child framework. If you have customized heavily the actual theme, upgrading may be a little more problematic. I have never had an issue upgrading. Just upload the theme as a zip file, extract to wp theme folder. done in 30s. There are a couple of SEO widgets I need to reset but beyond that I have never had a problem. Also, they must be getting close to automatic updates. The newer versions now have a notification box that tells you that a new update is available for install. have fun hatin ;) Bevj

Share this post


Link to post
Share on other sites
aemillerco

Hatin... lol. Yea, guess I am. This is WP. Using FTP is against all that WP is about so when I run into that, I can only assume the company is WAY behind. Thanks for your valuable feedback.

Share this post


Link to post
Share on other sites
Simon

Guys, we introduced update notifications in 1.4.x and FULL auto upgrades in 1.5.0, 1.5.1 was released last week and you would have been able to make use of the wordpress theme upgrade system.

Share this post


Link to post
Share on other sites
aemillerco

Well I am running 1.3.5! Wowsers... guess I need to do the manual thing.

Share this post


Link to post
Share on other sites
aemillerco

Thanks, Catrina. I followed those exact instructions (option 1) and all it saved was my logo and favicon. Every other option from every other pane within the platform pro settings was lost. 3 months of work on this site :( I went back and renabled the old version in the _old folder hoping to get the site back, and it's settings too are gone. :( SO... I attempted to use backup buddy to restore the site from a backup, and it too failed me by downbloading backupbuddy.php to my harddrive instead of running a restore. What a night!!! :(

Share this post


Link to post
Share on other sites
aemillerco

Not to mention i lost all custom menus too. This is exactly what I figured would happen based on the feedback to that upgrade article.

Share this post


Link to post
Share on other sites
catrina

Is there no backup of the theme that was saved prior to upgrading (your customized theme folder saved to your hard drive)?


Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
aemillerco

I was able to get it restored from backup buddy. Don't understand what went wrong though. Afraid to try it again. :(

Share this post


Link to post
Share on other sites
Simon

The only thing i can think is that when you upgraded, either the theme name or theme folder was different, this would cause it to use a new settings array.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×