Jump to content
Sign in to follow this  
jsilva7765

Vanishing WP Menus and SubMenus

Recommended Posts

jsilva7765

Hi All, I could really use some help on this. I am currently designing a site using PlatformPro for the theme and layout as well as WP-Member to track and control membership. I have disabled and re-enabled plugins and cant figure it out. Well what happens is I will create a WP Menu and add pages and sub pages. They seem to work fine then poof some randomly will disappear. Any ideas?

Share this post


Link to post
Share on other sites
timlinson

Do you have a live link? Do the pages themselves disappear or just the menu entries?

Share this post


Link to post
Share on other sites
jsilva7765

The pages do not disappear and I can use the permalink to access the page. So for example I have created a menu item out of an existing page and called it "X" well then I add a category item "B" and page "C" under "X". So sometimes "B" will show up but "C" will not and visa versa. But if I remove the entire menu item and re-create it they now show up "Sometimes" Now here is the weird thing, if you login to the site as a user you can normally see all of the menu items fine. But if you are say just browsing the site they may disappear. Have you ever heard of this?

Share this post


Link to post
Share on other sites
catrina

I haven't heard of this before. Can you post a link so we can check it out?


Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
jsilva7765

Sure the site URL is socialsimplicity.net

Share this post


Link to post
Share on other sites
kastelic

Are you using caching plugins? If so you should disable them when you are making changes.

Share this post


Link to post
Share on other sites
jsilva7765

Jimmy! Looks like it's not a cache issue but there is some issue between the "Post Types Order" plugin and Platform Pro. If there is a category in the menu it will not show anything below the category including pages. But if it's above a category menu everything shows fine. Thanks everyone for your help!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×