Jump to content
Sign in to follow this  
bizint

My Sub Page menu Widget doesnt appear with Blog type pages?!

Recommended Posts

bizint

Dont know if this is a plug in question - put I have a widget that appears in my sidebar showing a "sub menu" of the main nav bar...see this link below to see a nav on left with sub pages same as stnadrda above for "Procurement" http://www.businessinteriors.co.uk/betatest/wordpress/office-furniture The only place this sub menu doesnt appear is the Home page, although the Home page has some "child" pages I've used Widget Logic to hide it here. But strangely, it doesnt appear in the side bar for blog style pages? See my knowledge section: http://www.businessinteriors.co.uk/betatest/wordpress/knowledge Again you can see the sub menu on right - but if you click on News & Blog, The heirachy disappears...?! Any ideas why?!

Share this post


Link to post
Share on other sites
timlinson

Based on the breadcrumbs, it looks like News & Blog has no children. I think that sidebar menu is a secondary menu, so it only shows child menus.

Share this post


Link to post
Share on other sites
bizint

I'm not sure...for some reason it doesnt or wont show on the "blog" style pages....are these "categories" Any help or pointers appreciated as I love the side navigation - so would really like to figure out why it wont show!

Share this post


Link to post
Share on other sites
catrina

What sidebar are you using on the left side of the News & Blog page? I think you'll need to add a widget there for the subpage menu...


Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
bizint

Its the same as the other pages....so if you see "latest Project" the sub menu widget is always above it....yet flor some reason the widget doesnt appear in the "news" style pages...and I dont know why!

Share this post


Link to post
Share on other sites
catrina

I checked your source and it isn't hiding. It's just not there at all. Check your Breadcrumb NavXT settings in Widgets. Make sure that it's not set to hide on front page.


Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
bizint

Breadcrumb NavXT? The widget is "sub menu"...does Breadcrumb do the same? I have set the widget to hide on the front page...but its not appearing on the news pages....

Share this post


Link to post
Share on other sites
catrina

I thought widget you were referring to was Breadcrumb NavXT, not a plugin widget. They should function the same way.


Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
bizint

Its "submenu" widget...it appears in all my pages except the front page which I hid it on using widget logic....really frustrated that the menu system isnt working for the post/news pages and cant figure out why....

Share this post


Link to post
Share on other sites
kastelic

What code are you using in widget logic to hide it on the home page? Because I think if you're using

is_home()
that actually means the blog page, and
is_front_page()

refers to the "home" page.

Share this post


Link to post
Share on other sites
bizint

no I'm using is_front_page()to hide on front page only... I've tried to get round by inserting a custom menu - but that also has the same problem: This is my "blog" page with the two widgets that should be showing not showing (but one that is?!): http://www.businessinteriors.co.uk/betatest/wordpress/knowledge/news-blog'>http://www.businessinteriors.co.uk/betatest/wordpress/knowledge/news-blog This has exactly the same widget settings but is showing them: http://www.businessinteriors.co.uk/betatest/wordpress/knowledge I've set Knowledge as the parent - but why wont the sub page menu show in the news-blog page? But the other widget (latest product image) does show...?! I put in another custom widget menu, assuming a proble with sub page widget - and set it to show in just "knowledge" and its child "news-blog"...but that isnt showing in teh news-blog either (but it is in knowledge) using: is_page(array('knowledge','news-blog'))...this is working fine and showing in knowledge...but not in news-blog...why would these widgets show in "knowledge" but not "news-blog"?!....and even more so when the "latest project" widget does show in both?! In fact that is currently set to show in all - just like the sub page widget that mysteriuously disappears once a post style page is involved... please help! Days of hair pulling

Share this post


Link to post
Share on other sites
bizint

I tried the buddy press thing you said...but it made no difference. Also I think I'm right in saying that code would work if I only wanted it to show on that page - but with no code it should show on every page anyway? I'm trying to figure out why the menu widgets dont want to show on these blog pages... When you say it s a bp page...is it something unique to buddy press? Should I de-activate and see? This is doin my head in, I need a side menu in these post style news pages - at the moment I can only get a catgory widget to show...any attempt to put a navigation bar is being stumped?! Strange strange strange...waaahhh

Share this post


Link to post
Share on other sites
cmunns

BuddyPress pages are just difficult to give typical PageLines meta values to outside of the default because they are generated dynamically through the template pack plugin

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×