Jump to content
rmcotton

Randomizing the Feature Slides

Recommended Posts

rmcotton

Is there a way to randomize the slides that show up in the feature bar? I checked the Pagelines Settings Feature Section and the options within the page itself. I can't find anything pertaining to this. Any thoughts you have would be greatly appreciated. Happy Day! -Rachel

Share this post


Link to post
Share on other sites
cmunns

There is no option built-in but the js code can be added using you'd have to add some jquery to your head section ` ` It's not tested but should work fine.

Share this post


Link to post
Share on other sites
rmcotton

Adam: Thank you so much for attempting to help me out here. I added the exact script to the Header Scripts section under Custom Code. It still doesn't appear to be randomizing. The site is here: http://www.visitcoastalgeorgia.org Do you think that the other scripts on the page could be affecting this one? Or did I do it wrong. Again, your act of kindness in helping me out is so appreciated. Thank you.

Share this post


Link to post
Share on other sites
cmunns

Okay I just tested this and it works more or less, but you'll see the first image flash bc it's ocurring after the initial load ` `

Share this post


Link to post
Share on other sites
giannibaccega

hi, I've got the same problem, I'm trying that code you posted, copied it in the header scripts section (under custom code) but it doesn't work!

Share this post


Link to post
Share on other sites
rmcotton

It isn't working for me either. If you have any suggestions, Adam, we would appreciate it greatly! Are we putting it in the wrong place?

Share this post


Link to post
Share on other sites
cmunns

Rachel you are adding it before jQuery is included in the theme. Try adding it to your footer or at least load it after everything else in the head.

Share this post


Link to post
Share on other sites
rmcotton

OMG!! you are genius!! If you were right here, I would give you a big ole hug! Thank you so much for your patience. You are an angel. Please let me know if I can return the favor. Happy Day, Rachel

Share this post


Link to post
Share on other sites
giannibaccega

great, written the code in the footer and it's working! the only problem is that I was using the slide transition, not the fade one. Is it possible to change it? Thanks

Share this post


Link to post
Share on other sites
mending

Hi there, Why does the script eliminate all Feature Viewing Time and Transition Effect settings in the "Feature Settings" ? Is it not possible to randomize the features yet keeping its settings in place?

Share this post


Link to post
Share on other sites
clneon
I would also like to randomize the slides that load in the feature slider. I've tried the code you posted, copied it in the footer scripts section (under custom code) but it doesn't seem to work! Any ideas on what might be wrong? Randomize the loading order would be nice addition to future upgrades.

Share this post


Link to post
Share on other sites
clneon
Also, I assume this code randomizes all feature slider sets not just a specific one?

Share this post


Link to post
Share on other sites
logotel
Hi, I modified the file: "section.features.php" replacing: $query['orderby'] = 'ID'; with: $query['orderby'] = 'rand'; Every time you enter the page with the feaures slider the list of features is reorganized. :)

Share this post


Link to post
Share on other sites
thesecretservice
Hi, I have tried to place this code in the custom code, footer scripts section of platform pro but it's not working. Can anybody help me and explain what I'm doing wrong? ` var $j = jQuery.noConflict(); $j(document).ready(function() { $j('#cycle').cycle({random:'1'}); }); `

Share this post


Link to post
Share on other sites
thesecretservice
Thank you Catrina, I got it to work but now I have lost Feature Viewing Time. I had it set to 10 secs but now it changes every 2 secs. Can someone help me fix this?

Share this post


Link to post
Share on other sites
catrina
Have you tried setting the viewing time again and saving or does it keep reverting to 2 seconds?

Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
thesecretservice
Hey Catrina, I tried that but it keeps reverting to 2 secs.

Share this post


Link to post
Share on other sites
mwilson51
Thanks for the code! It works, but as thesecret service stated, you lose control over transition timing. Is there any way to fix this in the code?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×