Jump to content
Sign in to follow this  
sarahwhite

Display Video and audio on Blog (Home) Page

Recommended Posts

sarahwhite

Hey all, I have video and audio that I would like to appear on the main blog listings page, not just on the single post page. You can see this with the top two posts here: http://nakedtherapy.org/ The code for Recent "Press on Weinergate" that isn't displaying is: <script type="text/javascript" src="http://video.foxbusiness.com/v/embed.js?id=992085084001&w=466&h=263"></script><noscript>(Click title of post above to see video!)</noscript> The code for "Carli's First Radio Interview" that isn't displaying is: [audio:http://sarahwhitetherapy.com/wordpress/wp-content/uploads/2011/04/CarliMoore-NakedTherapist-061311-_Edit1.mp3|titles=CarliMoore-NakedTherapist-061311-_Edit1] For other problems of this sort I have gone to Platform Pro Settings > Blog and Posts > Allowed Tags And entered in tags such as: <object><embed> I've tried, and the theme won't "allow" <script> or <audio>. Is there some other way I make it so the full video script is displayed, and the audio is displayed, on the full blog list page? Thanks very much for any advice! Sarah

Share this post


Link to post
Share on other sites
catrina

The video and audio isn't displaying on the blog list page because you have excerpts enabled instead of full post content. To ensure the video/audio displays, you can go to Settings > Blog And Posts and adjust your excerpt and full post content settings.


Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
sarahwhite

Hi Catrina, But I don't want the full post to show on my blog list page. I want the excerpt to show, and I want the excerpt to include the audio and video. Does that make sense? Thanks! Sarah

Share this post


Link to post
Share on other sites
sarahwhite

By the way - the two posts I am referring to are now #3 and #4 on the blog list.

Share this post


Link to post
Share on other sites
cmunns

You can show excerpts of the "full post" by adding the `` tag to each post where you want the excerpt to stop. Try that otherwise you need to allow the actual traditional excerpt to display these tags by adding them to the Page and Post options

Share this post


Link to post
Share on other sites
sarahwhite

Thanks very much for that, Adam. I like the length that the excerpt cuts off at automatically, so ideally I will still use the excerpt - but it's good to know <!--more--> tag works! Can you tell me what you mean by 'allowing them to display these tags in the Page and Post options'? I've already allowed <script> and <audio> in the Page and Post options, but it doesn't seem to actually be allowing them as they aren't being displayed. Am I using the wrong tags? Thanks very much!

Share this post


Link to post
Share on other sites
timlinson

In PlatformPro > Settings > Blog and Posts, there's an "Allow Tags in Excerpt" field. You should add each of those embed tags that you're wanting to show up in excerpts.

Share this post


Link to post
Share on other sites
sarahwhite

Yes, I've already "allowed" <script> and <audio> but it is still not working. The code I'd like to have displayed is in my first post. Am I trying to allow the incorrect tags? Thanks.

Share this post


Link to post
Share on other sites
sarahwhite

Thanks, Adam. Tried that and still not working.

Share this post


Link to post
Share on other sites
sarahwhite

Shall I assume this is a lost cause?

Share this post


Link to post
Share on other sites
catrina

Excerpts don't even allow images, so video/audio is on the same boat. Maybe it could be done, but with customization that overrides what WordPress allows.


Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
timlinson

There are also advanced excerpt plugins you can try.

Share this post


Link to post
Share on other sites
sarahwhite

Thanks for the ideas. I have allowed the tags and it isn't working. Can someone pass that on to the developers to look at? Adam - I've decided to use the <!--more--> tag as you suggested. When I use it, however, if I click "Continue reading" it takes me to wherever the <!--more--> tag is in the code when the single post opens. Is it possible to make it so when I click "Continue reading" it goes to the beginning of the single post as if I had clicked on the title? Thanks, Sarah

Share this post


Link to post
Share on other sites
sarahwhite

Works perfectly, Thanks Catrina!

Share this post


Link to post
Share on other sites
sarahwhite

This is all, except that I would like pass on to the developers that allowed tags aren't working for <script>. How do I do that?

Share this post


Link to post
Share on other sites
catrina

I can mark this topic for developer attention and one of the developers can check it out.


Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×