Jump to content


Photo
- - - - -

updating permalinks?


  • Please log in to reply
6 replies to this topic

#1 krumvillebakeshop

krumvillebakeshop

    Advanced Member

  • Members
  • PipPipPip
  • 93 posts

Posted 15 May 2011 - 06:29 PM

I'm almost finished with my site and a friend told me I should change the permalinks so they are relevant to the page you are in. I found a widget (Permalink Redirect) that changes them automatically to a page name but of course it doesn't work! I get a 404 page error and it only goes away when I deactivate the plugin. does anyone know a different way to change them? or are there other steps I should take before? thank you so much! any help would be amazing!

#2 catrina

catrina

    Advocate

  • Members
  • 12345 posts
  • LocationCalifornia
  • Country: Country Flag

Posted 15 May 2011 - 06:45 PM

Rather than using a plugin, you can go to Settings > Permalinks on your Dashboard, then select "Day and name" under Common settings, and then save. That way, you posts and pages would automatically contain names rather than numbers.

#3 krumvillebakeshop

krumvillebakeshop

    Advanced Member

  • Members
  • PipPipPip
  • 93 posts

Posted 15 May 2011 - 07:14 PM

hi Catrina, I tried that just a while a go and is giving me the same 404 page error. :(

#4 krumvillebakeshop

krumvillebakeshop

    Advanced Member

  • Members
  • PipPipPip
  • 93 posts

Posted 15 May 2011 - 07:27 PM

i tried again and I'm getting this note, not sure what to do with this. "if your .htaccess file were writable, we could do this automatically, but it isn??™t so these are the mod_rewrite rules you should have in your .htaccess file. Click in the field and press CTRL + a to select all." <IfModule mod_rewrite.c> RewriteEngine On RewriteBase / RewriteRule ^index.php$ - [L] RewriteCond %{REQUEST_FILENAME} !-f RewriteCond %{REQUEST_FILENAME} !-d RewriteRule . /index.php [L] </IfModule>

#5 kastelic

kastelic

    Advocate

  • Members

  • 3081 posts
  • Country: Country Flag

Posted 15 May 2011 - 09:01 PM

What the note is saying is that you have to copy and paste this code and paste it in the file named .htaccess in the root directory of your installation. Either that or contact your hosting provider about making that file writable, they'll know what you're talking about.

#6 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 15 May 2011 - 09:02 PM

You need to create a new file called `.htaccess` and copy that text into it, and upload it to your blogs directory.

Thats `.htaccess` NOT `htaccess.txt` or `.htaccess.txt`

#7 krumvillebakeshop

krumvillebakeshop

    Advanced Member

  • Members
  • PipPipPip
  • 93 posts

Posted 15 May 2011 - 10:50 PM

got it! thank you guys! enjoy your sunday evening!