• 0
Sign in to follow this  
Followers 0

bbpress deep integration

Question

Posted · Report post

Hello, I am having trouble getting my wp installation and my bbpress forum to deep integrate. here is the code I used. require_once(dirname(__FILE__) . '/home/mnewton/public_html/wp-load.php'); here is the error I receive. Warning: require_once(/home/mnewton/public_html/forum/home/public_html/wp-load.php) [function.require-once]: failed to open stream: No such file or directory in /home/mnewton/public_html/forum/bb-config.php on line 66 Fatal error: require_once() [function.require]: Failed opening required '/home/mnewton/public_html/forum/home/public_html/wp-load.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/mnewton/public_html/forum/bb-config.php on line 66 Can you help?

Share this post


Link to post
Share on other sites

24 answers to this question

  • 0

Posted · Report post

looks like the file path is wrong. Try using the full absolute url (http:// etc.)

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Thank you for the quick reply! Here is what I put in... require_once(dirname(__FILE__) . 'http://specialneedsconnections.com/wp-load.php'>http://specialneedsconnections.com/wp-load.php''>http://specialneedsconnections.com/wp-load.php'>http://specialneedsconnections.com/wp-load.php'); This is the error.. Warning: require_once(/home/mnewton/public_html/forumhttp://specialneedsconnections.com/wp-load.php'>http://specialneedsconnections.com/wp-load.php) [function.require-once]: failed to open stream: No such file or directory in /home/mnewton/public_html/forum/bb-config.php on line 66 Fatal error: require_once() [function.require]: Failed opening required '/home/mnewton/public_html/forumhttp://specialneedsconnections.com/wp-load.php'>http://specialneedsconnections.com/wp-load.php''>http://specialneedsconnections.com/wp-load.php'>http://specialneedsconnections.com/wp-load.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/mnewton/public_html/forum/bb-config.php on line 66

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

oh sorry, take out the dirname like this:

require_once 'http://specialneedsconnections.com/wp-load.php';

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Have you tried this way, (from the docs): so if your bbPress folder is directly inside your WordPress folder, the command becomes require_once(dirname(__FILE__) . '/../wp-load.php');) This is probably the one your looking for.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Got it, now we're getting somewhere! When I go there now all that I see is a blank page. No errors though.... How do I go about fixing that?

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

So you have installed bbpress correctly and it was working but but only found errors after trying to deep integrate?

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Correct, I was able to have full access until I switched to pagelines bbforum theme and added the line of code that we have been talking about. The cookie integration was just fine as well. Now it is still just a blank page that comes up. :

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Correct, I was able to have full access until I switched to pagelines bbforum theme and added the line of code that we have been talking about. The cookie integration was just fine as well. Now it is still just a blank page that comes up. :

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Sorry I didn't mean to send that twice.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

. If you deactivate the pagelines bbforum theme does it work?

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

No I still cannot get it to load the page. It still seems to be a blank page when going there.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

If you deactivate the theme and also remove the line what do you see?

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

It works.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

That was the reason I bought the PageLines platform was for the BBPress Forum.....

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

and your adding the line at the very top of bb-config.php?

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Yes I have tried both ways top and also the bottom before the language tag

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

It needs to be at the very top and also within <?php ?> tags. So either wrap it in those tags or put it somewhere below the first <?php , but above everything else.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Gotcha. As soon as I am back home I'll give it a try if I have an issue I'll repost. Thank you so much for your help thus far.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Unfortunately that still gives me a blank page?

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Can you paste the section of code where you placed that line?

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

<?php require_once(dirname(__FILE__) . '/../wp-load.php'); /**?  ? * The base configurations of bbPress. ? * ? * This file has the following configurations: MySQL settings, Table Prefix, ? * Secret Keys and bbPress Language. You can get the MySQL settings from your ? * web host. ? * ? * This file is used by the installer during installation. ? * ? * @package bbPress ? */ // ** MySQL settings - You can get this info from your web host ** // /** The name of the database for bbPress */ define( 'BBDB_NAME', 'mnewton_wdps1' ); /** MySQL database username */ define( 'BBDB_USER', 'mnewton_wdps1' ); /** MySQL database password */ define( 'BBDB_PASSWORD', 'K5SUeBbxqnq1N9YI' ); /** MySQL hostname */ define( 'BBDB_HOST', 'localhost' ); /** Database Charset to use in creating database tables. */ define( 'BBDB_CHARSET', 'utf8' ); /** The Database Collate type. Don't change this if in doubt. */ define( 'BBDB_COLLATE', '' ); /**#@+ ? * Authentication Unique Keys. ? * ? * Change these to different unique phrases! ? * You can generate these using the {@link https://api.wordpress.org/secret-key/1.1/bbpress/ WordPress.org secret-key service} ? * ? * @since 1.0 ? */ define( 'BB_AUTH_KEY', 'V636!jmw@GxJ#??n(2^yan@66LdKOo0nVA7/yG*):-:|It>;qnfV5W)@^x0mUu6o' ); define( 'BB_SECURE_AUTH_KEY', 'L<,mo1^*3/qwVvc=:P$2`J32RI

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Well, looks like you included the line correctly. If it works fine and then you get a blank page just by adding a php include then I think you've got some problem with your server. I would contact them Maybe PHP is running out of memory or something. I see no other reason you should be stuck at this point. Either the file directory will be wrong and you get the error you saw before, or it will be right and you will should not notice any change. Once your host figures out the problem it should be a snap to activate the theme.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Okay, sorry I didn't respond until now as I was working for most of the day. After talking to my hosting company and LOTS of time Google. I found an post in the PageLines forum. http://pagelines.com/forum/topic/8554 It states that the WP Super Cache plugin may have something to do with it. Interestingly enough as soon as I disabled that plugin my forum is exactly what I wanted it to be! Thank you guy's so much for all of your support. I feel I made a good decision buying your software. -Matt

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0