Jump to content


Photo
- - - - -

Morefoot and Footer Not Showing


  • Please log in to reply
17 replies to this topic

#1 hakatours

hakatours

    Advanced Member

  • Members
  • PipPipPip
  • 36 posts

Posted 09 April 2011 - 04:22 AM

Hi guys Just started editing my site today. I could be doing something really stupid, but I can't get the Morefoot and Footer areas to show on any of the pages. I haven't hidden it on the pages themselves! Anyone got any ideas?? If you need to see the site it is www.hakalodge.com. It's at the very start of creation! Thanks

#2 catrina

catrina

    Advocate

  • Members
  • 12345 posts
  • LocationCalifornia
  • Country: Country Flag

Posted 09 April 2011 - 05:36 PM

Go to Settings > Template Setup > Select Site Footer from the Select Template Area and enable the morefoot area and any other areas you want in the footer by dragging them from the right to the left section.

#3 hakatours

hakatours

    Advanced Member

  • Members
  • PipPipPip
  • 36 posts

Posted 11 April 2011 - 03:39 AM

Thanks but I have already done this. That's why I'm confused! Any other ideas why it isn't showing?

#4 ricardo

ricardo

    Advocate

  • Members
  • 587 posts

Posted 11 April 2011 - 04:08 AM

I was looking at your html and it looks like you edited the php files. Did you?

#5 timlinson

timlinson

    Advocate

  • Members
  • PipPipPipPipPip
  • 1032 posts

Posted 11 April 2011 - 04:16 AM

If you used markup tags anywhere, double check that none are unclosed/mismatching.

#6 hakatours

hakatours

    Advanced Member

  • Members
  • PipPipPip
  • 36 posts

Posted 13 April 2011 - 03:02 AM

Haven't edited the php no. When I put the address into a markup validator, it tells me the below. Can anyone explain whether this is the reason behind my footer not showing and any ideas how to change it? Line 439, Column 23: there is no attribute "role" <div id="footer" role="contentinfo"> You have used the attribute named above in your document, but the document type you are using does not support that attribute for this element. This error is often caused by incorrect use of the "Strict" document type with a document that uses frames (e.g. you must use the "Transitional" document type to get the "target" attribute), or by using vendor proprietary extensions such as "marginheight" (this is usually fixed by using CSS to achieve the desired effect instead). This error may also result if the element itself is not supported in the document type you are using, as an undefined element will have no supported attributes; in this case, see the element-undefined error message for further information.

#7 timlinson

timlinson

    Advocate

  • Members
  • PipPipPipPipPip
  • 1032 posts

Posted 13 April 2011 - 03:37 AM

Sounds like you validated against xhtml. The site uses html5 doctype, and the only errors I get when I validate for html5 are for unclosed div tags.

Please Login or Register to see this Hidden Content



#8 hakatours

hakatours

    Advanced Member

  • Members
  • PipPipPip
  • 36 posts

Posted 13 April 2011 - 11:17 AM

Yup so I did! Changed it. Still not resolved the issue of my disappeared footer. Can anyone give me any other ideas as why it isn't showing up? I'm at a complete loss. Very frustrating.

#9 Kate

Kate

    Advocate

  • Members
  • 3039 posts

Posted 13 April 2011 - 12:49 PM

Hi Ellen,
I'm actually seeing your footer. It says:

Quality Christchurch Backpackers Accommodation - Haka Lodge is proudly powered by WordPress
Entries (RSS) and Comments (RSS).



#10 hakatours

hakatours

    Advanced Member

  • Members
  • PipPipPip
  • 36 posts

Posted 13 April 2011 - 10:28 PM

I see that too! But it's not what I have programmed - I have a footer and have dragged and dropped in Morefoot 3 Sidebars + Simple Footer Navigation - this is what isn't appearing! I also have uploaded an image and changed the text within the Footer settings.

#11 timlinson

timlinson

    Advocate

  • Members
  • PipPipPipPipPip
  • 1032 posts

Posted 14 April 2011 - 03:13 AM

I haven't hidden it on the pages themselves!


Don't know if you've checked this too, but on the "Morefoot 3 Sidebars" and "Simple Footer Navigation" boxes, click Advanced Setup and make sure "Hide by Default" didn't get checked somehow.

#12 hakatours

hakatours

    Advanced Member

  • Members
  • PipPipPip
  • 36 posts

Posted 14 April 2011 - 03:31 AM

Nope, not that! Thanks for the suggestion tho!

#13 timlinson

timlinson

    Advocate

  • Members
  • PipPipPipPipPip
  • 1032 posts

Posted 14 April 2011 - 04:05 AM

I've flagged this for the devs. Just for more info, do you know where this content is coming from?

Quality Christchurch Backpackers Accommodation - Haka Lodge is proudly powered by WordPress
Entries (RSS) and Comments (RSS).


It's getting put in your #footer div, so it would help to know where this text was defined.

#14 Kate

Kate

    Advocate

  • Members
  • 3039 posts

Posted 14 April 2011 - 04:58 AM

@Tim TTBOMK that's just the default WP footer info, isn't it?

#15 timlinson

timlinson

    Advocate

  • Members
  • PipPipPipPipPip
  • 1032 posts

Posted 14 April 2011 - 05:25 AM

ah yes you're right, it's pulling from wp-includes/theme-compat/footer.php

#16 cmunns

cmunns

    Advocate

  • Members

  • 6537 posts
  • Country: Country Flag

Posted 14 April 2011 - 06:15 PM

Not sure why the WP footer is interfering with the theme. Do you have any plugins installed that tap into WP core files?

#17 cshoffmann

cshoffmann

    Advocate

  • Members
  • 262 posts

Posted 14 April 2011 - 11:52 PM

Ellen, as we discussed via email, it is my diagnosis that you need to reinstall the Platform Pro (not PPBase). It appears that 1) you PP installation is not correct and currently your site is only running on PPBase 2) you are in need of the latest upgrade to 1.3.5. I believe once you have the PP 1.3.5 installed or the latest version, you will then see the footer appear with the PPBase activated. Follow the instructions for upgrading that I sent via email. Follow up here in the forum with your results.

#18 hakatours

hakatours

    Advanced Member

  • Members
  • PipPipPip
  • 36 posts

Posted 15 April 2011 - 03:24 AM

Shaun's advice was correct - the footer is now showing after installing the new version of Platform Pro and activating Base. Thanks!!