Jump to content


Photo
- - - - -

setting home page


  • Please log in to reply
8 replies to this topic

#1 jenny20k

jenny20k

    Super Member

  • Members
  • PipPipPipPip
  • 100 posts

Posted 03 April 2011 - 05:11 PM

Hi I deleted the sample page and now my "home page" has its own permalink. However, my site branding goes to simply the .com page. This is a problem as the .com page shows different content. How can I reset the permalinks? I have looked at the wp guidance but keep making a mess of it. www.creativecheshire.com

#2 catrina

catrina

    Advocate

  • Members
  • 12345 posts
  • LocationCalifornia
  • Country: Country Flag

Posted 03 April 2011 - 05:32 PM

Permalink settings can be adjusted in Settings > General, but I'm not sure if the issue can be resolved there since it's only for setting up page/post permalinks. What is the permalink that results for your home page?

#3 jenny20k

jenny20k

    Super Member

  • Members
  • PipPipPipPip
  • 100 posts

Posted 03 April 2011 - 07:49 PM

Hi Thanks for your quick post. The home page I have made has the permalink /?page_id=2 However, in my wordpress settings, the website url is simply ".com"

#4 kastelic

kastelic

    Advocate

  • Members

  • 3081 posts
  • Country: Country Flag

Posted 03 April 2011 - 09:55 PM

Try going into Settings ->Permalinks and selecting "custom structure" and then paste in /%postname%/ and save.

#5 jenny20k

jenny20k

    Super Member

  • Members
  • PipPipPipPip
  • 100 posts

Posted 03 April 2011 - 10:17 PM

Thanks - however, I still have the problem that when I click on the branding icon/ just type my url in, I get a post page - as opposed to my customised home page. My wp reading settings don't show me the option to change my homepage for a static one - I'm not sure why.

#6 kastelic

kastelic

    Advocate

  • Members

  • 3081 posts
  • Country: Country Flag

Posted 03 April 2011 - 10:26 PM

So you want your homepage to be a static page right? Have you set up your main navigation menu manually in Settings -> Menu, after making a page called "home"?

#7 jenny20k

jenny20k

    Super Member

  • Members
  • PipPipPipPip
  • 100 posts

Posted 03 April 2011 - 10:59 PM

I can get the nav button to go to my static home page (.com/home/) but my web address still goes to the post page, as does the branding icon.

#8 kastelic

kastelic

    Advocate

  • Members

  • 3081 posts
  • Country: Country Flag

Posted 03 April 2011 - 11:28 PM

So, in Settings->Reading, you say that you cannot set your home page to a static page? Why not? If this feature is totally gone you either have a plugin conflict or a corrupt installation. If you can set it there, but there is no change, perhaps you have some redirection somewhere in .htaccess or in your hosting providers admin?

#9 jenny20k

jenny20k

    Super Member

  • Members
  • PipPipPipPip
  • 100 posts

Posted 04 April 2011 - 06:43 AM

Bizarrely, the option has just come back - I swear it hasn't been there for days! Ah well, all sorted now, thanks though!