Jump to content


Photo
- - - - -

Theme Performance in WHP


This topic has been archived. This means that you cannot reply to this topic.
3 replies to this topic

#1 dscouron

dscouron

    Member

  • Members
  • PipPip
  • 29 posts

Posted 25 February 2010 - 03:29 AM

I've added quite a bit of code to the custom css and changed around some of the php files and noticed that the load time and performance has lagged a little bit. I'm planning on going back and making sure all my images are optimized to help with load times, but I was wondering if you had any advice on some basic steps to help the theme load as quickly as possible.

#2 jnoh

jnoh

    Advocate

  • Members
  • PipPipPipPipPip
  • 502 posts

Posted 25 February 2010 - 03:37 AM

dscouron, do you have a lot of plugins enabled?

#3 dscouron

dscouron

    Member

  • Members
  • PipPip
  • 29 posts

Posted 25 February 2010 - 03:44 AM

No, I really don't. I've installed 16 plugins and currently have 9 of them enabled, but there plugins like sitemaps and seo. I'm guessing that a majority of the issues are with loading images that don't need to be at such high qualities. But I did notice in firebug that the style.css is called, then all the custom code is added afterwords. If that is case, would it make sense to make the changes to the actual style.css and leave the custom code empty?

#4 jnoh

jnoh

    Advocate

  • Members
  • PipPipPipPipPip
  • 502 posts

Posted 25 February 2010 - 03:55 AM

ooo. if you do have a lot of custom code, making the changes to the actual style.css file will add make it a bit more snappy as it doesn't have to dl/process the code on every page-load. Large images can also slow down load times as you've rightfully pointed out.