Archived

This topic is now archived and is closed to further replies.

Theme Performance in WHP

4 posts in this topic

Posted · Report post

I've added quite a bit of code to the custom css and changed around some of the php files and noticed that the load time and performance has lagged a little bit. I'm planning on going back and making sure all my images are optimized to help with load times, but I was wondering if you had any advice on some basic steps to help the theme load as quickly as possible.

Share this post


Link to post
Share on other sites

Posted · Report post

dscouron, do you have a lot of plugins enabled?

Share this post


Link to post
Share on other sites

Posted · Report post

No, I really don't. I've installed 16 plugins and currently have 9 of them enabled, but there plugins like sitemaps and seo. I'm guessing that a majority of the issues are with loading images that don't need to be at such high qualities. But I did notice in firebug that the style.css is called, then all the custom code is added afterwords. If that is case, would it make sense to make the changes to the actual style.css and leave the custom code empty?

Share this post


Link to post
Share on other sites

Posted · Report post

ooo. if you do have a lot of custom code, making the changes to the actual style.css file will add make it a bit more snappy as it doesn't have to dl/process the code on every page-load. Large images can also slow down load times as you've rightfully pointed out.

Share this post


Link to post
Share on other sites