• 0
Sign in to follow this  
Followers 0

How do I get rid of the comment box on my main static page? WHPRO

Question

Posted · Report post

I read one solution to put a line of code in the HTML that actually made it go away...but it came back...with a vengeance!

Share this post


Link to post
Share on other sites

9 answers to this question

  • 0

Posted · Report post

You should be able to just go to SETTINGS - DISCUSSIOn and disable comments on pages.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Don't see that option in the settings for discussion..is it worded differently and maybe i'm missing it!

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Are you using WordPress 3.1? The "Discussions" section is disabled by default for some reason, so to turn it back on click edit on any page (doesn't matter which one) and click the "screen options" tab in the top right and check off the discussions radio box. Now you should see the option to disable comments on pages.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Hey, I'm getting this problem as well. I have tried doing so through "Discussions" but to no avail.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

That's strange. Okay well you'll need to go the Pages tab. Select all the pages and bulk edit. Then uncheck "allow comments"

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Ok...I got it...I didn't find it until I went to the Pages tab and hit "quick edit" on the page I wanted to remove the comment form. ( bulk edit didn't reveal any way to uncheck "allow comments") over to the right side where it says Parent Order Template just below Template there is an option to turn off Comments !!! Wow..that just took way too long to find! LOL

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Just wanted to say thanks as I has this issue, too. I followed Deborah's lead. Works for me!

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Cool Mick..good to know I was able to help out!

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Thanks. This worked for me. I was getting tons of comment spam on my static pages. Now I hope to get none.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0