• 0
Sign in to follow this  
Followers 0

Videos not loading on search results

Question

Posted · Report post

I have posts that I am using the JWPlayer plugin to embed videos in. I am using the JWPlayer shortcodes. When I run a search and posts with video in them show up, there is no video, just the poster image I supply for the video. When I click on the post title and go to the individual post page, everything works fine. So I was wondering how to get the videos to show up on the search results page, or is this a problem with the JWPlayer plugin?

Share this post


Link to post
Share on other sites

7 answers to this question

  • 0

Posted · Report post

Depends on how you are showing posts on the blog page. Also might be related to the plugin options, but I'm not sure which with little info.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

The JWPlayer plugin works on the single post page, and the blog page. It's only on the search results page that it isn't working. I have been looking at _posts.php to see if I could find anything that renders the shortcode before jwplayer gets to it but so far I haven't spotted anything. http://l2digital.com/?s=sizzle That's the page I am having problems with. If you go to the single post page from there you will see how the video is supposed to load. From what I can tell something gets to the jwplayer shortcode before the jwplayer plugin gets a chance to run, but that is really just a guess at this point.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Luis, have you looked into the video search plugin Bryan mentioned. Will that work for you?

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

I am having this same issue. We would like to show the full blog posts on /tag/ pages but when we do if there is are any players embedded the shorthand is displayed instead of the actual player. We are using iBlogPro but seems to be the same issue. Does this sound like a limitation of the theme or the JWPlayer for WP plugin?

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

It might strip tags...what if you set it in the excerpt portion of the post instead of having it auto shorten via the content?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0