• 0
Sign in to follow this  
Followers 0

Platform Base 1.3.1 is not working (

Question

Posted · Report post

I'm witnessing a strange behavior of the platform pro theme ever since I updated to the newest version of Platform Pro:

#boxes .dcol-pad {
	    background-color: #F3F3F3;
	    border: 1px solid #DEDEDE;
	    height: 120px;
	    margin: 5px;
	    padding: 5px;
	}

When I enter this code into the custom code section it does what it is supposed to do - it creates a greyish background to the boxes. When I enter the same code into the base-child theme it is not recognized. While at the same time a different line of code IS recognized. (For example: I changed the font-family to Arial, sans-serif via the child theme. When I delete this line of code, font-family styling falls back to the original PlatformPro version.) I can easily recreate this behavior with any other lines of CSS. I am running my blog on WP Version 3.1 and the newest version of the Platform Pro (1.3.0.2) + PlatformBase (1.3.1). My blog is password-protected at the moment so I cannot provide a link here. I'd very much appreciate your help. Thanks Christian

Share this post


Link to post
Share on other sites

9 answers to this question

  • 0

Posted · Report post

Sounds like a specificity issue, I'll look at it.. In base.css just add `body` or `#page` in front of any CSS rule and it should work. e.g. `#page #boxes .dcol-pad`

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Thanks! I tried it but unfortunately it still doesn't work. Any other suggestions what might work?

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Ok, live link? What is Firebug telling you?

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

The changes in base.css do not apply. According to Firebug the styling is

#boxes .dcol-pad {
	    padding: 8px 0 0;
	}
. Although it should be
#body #boxes .dcol-pad {
	    background-color: #F3F3F3;
	    border: 1px solid #DEDEDE;
	    height: 120px;
	    margin: 5px;
	    padding: 5px;
	}

I disabled the password protection for the moment. The live link would be: http://krimtheo.criminologia.de/theorien

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Hey Christian - Not sure what you mean by "it should be", but one thing I noticed is you're putting a "#" before body, where you really don't need to ;)

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Hello Kate, of course you're right - I don't need the "#". But it doesn't change anything. When I wrote "should be" I was referring to the difference between what it says in Firebug currently and what it should say. As mentioned above my base.css file isn't recognized by the Parent theme anymore.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Did you disable ajax saving. We have experienced some people having issues with ajax saving in Base and thus added an option for it

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

@Christian, I think this is a CSS Syntax error which we don't see often. Related to the special characters in this word: ???“bersichtsseite

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Thanks Adam, thanks Andrew, I followed both your advises but neither worked for me. Finally I deleted and re-installed the Base-theme and everything is working again. Sorry, I should have tried that earlier. Thanks for your effort anyway.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0