• 0
Sign in to follow this  
Followers 0

Hardcoding Subdomain header to link to main domain home page

Question

Posted · Report post

I have a site that consists of a main domain and (1) subdomain. Can anyone help with how to hardcode the header image link in the subdomain to redirect to the main domain homepage..?

Share this post


Link to post
Share on other sites

11 answers to this question

  • 0

Posted · Report post

Hi Curtis - Is the PageLines theme installed in the subdomain?

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Yes, both the domain & subdomain are running platform pro & base.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Curtis, you can use the pagelines_site_logo filter to change the image href location: The forum broke my code here is a pastebin: http://pastebin.com/f0QBrvFE

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Does this go in the functions.php..?

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Does this go in the functions.php..?
If you are using a child theme yes.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

This is what I've done, but it doesn't seem to do anything..? Located in base/functions.php wq09p.png

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Ahh yes, slight typo http://pastebin.com/3RErVwqk This snippet actually works as promised! Tested just now on my dev box.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

It still seems to do nothing for me..? I am however working inside of my "localhost" on my computer at the moment (waiting on some DNS transfers) then I can try this within the live server environment and maybe it will function properly... Hopefully, I'll be able to give this a try within a couple of hours or so...

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

It still seems to do nothing for me..?
Stab in the dark, you have setup a custom logo right? The filter only applies to custom logos.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Yep, custom logo uploaded as site header.

Share this post


Link to post
Share on other sites
  • 0

Posted · Report post

Thanks for the help here... I may never get to know if it actually works... I stumbled upon a fantastic plug-in that allowed for this as well as the ability to create custom headers for any page within the site... Thanks.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0