Jump to content


Photo
- - - - -

Add Social Media Icons


  • Please log in to reply
34 replies to this topic

#21 vauxflow

vauxflow

    Advanced Member

  • Members
  • PipPipPip
  • 39 posts

Posted 15 February 2011 - 10:28 PM

Ok now I'm totally lost. Can someone simply give me the block script that I need to paste in so that I can add additional icons that work exactly the same as my current ones (grey to color on hover) As I stated, I'm new to this so I need only the block script that will achieve what I want and also where or what php files I need to paste it into. Thanks

#22 vauxflow

vauxflow

    Advanced Member

  • Members
  • PipPipPip
  • 39 posts

Posted 16 February 2011 - 12:52 PM

Ok so have been trying to figure this out myself and now after altering the functions.php file I can no longer access my wordpress site, in fact it doesnt appear any longer at all, instead I get this code in the browser: Parse error: syntax error, unexpected '}' in /home/ctechweb/public_html/savelennox/wordpress/wp-content/themes/platformbase/functions.php on line 1 Luckily I was able to upload a backup functions.php file and overwrite the screwed up one so now at least the site is back online. Please can anyone help with this as I'm now so fed up with trying to add a few simple icons and being unable to that I'm now thinking of completely junking the whole Platform stuff. I just want a little clear direction as to what script needs altered and where so that I can add social icons that will function as my current ones. As said I am new to this and trying my best to help myself but instead I'm making a bad job of it. I know this will be simple for someone who has experience but I do not hence my questions. Been at this now for almost 4 days and it getting stupid now.

#23 Kate

Kate

    Advocate

  • Members
  • 3039 posts

Posted 16 February 2011 - 02:30 PM

Hi Craig - Since you're really struggling with this, you can e-mail us and we can implement it (assuming you have the new image ready to go). Also: the code I listed above is necessary as that's how the "current" icons work too. It takes two parts: adding code in functions.php, and adding code to the CSS. ;)

#24 vauxflow

vauxflow

    Advanced Member

  • Members
  • PipPipPip
  • 39 posts

Posted 16 February 2011 - 03:54 PM

Hi Kate, yes the icons I have made have been ready for days now and uploaded to my server, I just need help with the script to make them appear and link to the accounts required, as said I have little understanding of this at present so if possible baby steps please. I have sent an email ref this topic as requested. Thanks

#25 vauxflow

vauxflow

    Advanced Member

  • Members
  • PipPipPip
  • 39 posts

Posted 17 February 2011 - 12:30 AM

Still trying to figure this out, any chance Support could help with this please, almost 5 days now still messing about with this. Starting to think this was a bad purchase.

#26 Kate

Kate

    Advocate

  • Members
  • 3039 posts

Posted 17 February 2011 - 03:56 AM

Hi Craig - Just e-mailed you back about this. Please check it out, and reply with the info when you get the chance. All the best, Kate

#27 vauxflow

vauxflow

    Advanced Member

  • Members
  • PipPipPip
  • 39 posts

Posted 17 February 2011 - 06:33 PM

Really getting p***ed with this now. Isn't there just a simple way to add icons, reorder them in a way which I want them and not the template and to have the URL's correctly linked to the correct icons. Almost a week messing around with this, bit stupid now really.

#28 vauxflow

vauxflow

    Advanced Member

  • Members
  • PipPipPip
  • 39 posts

Posted 17 February 2011 - 07:30 PM

Ok, I know very little as to CSS coding and stuff so hopefully someone can help me with this so that I can wrap this whole nightmare up and move on to other things as this has went on far too long already. I simply want to add a few social icons to my site, link them to the correct URL's and below I have added an image of the total amount of icons I wish to have on my site and the order I wish to have them without the Platform Template dictating where I can and can't have them. Thanks in advance to any nice person that can help a total newbie.

Posted Image

I probably should have stated that my RSS icon is already in the correct place on the site and that the RSS icon is the only one I don't need to adjust in any form.

#29 Kate

Kate

    Advocate

  • Members
  • 3039 posts

Posted 17 February 2011 - 08:51 PM

Hey Craig - When you re-ordered them, did you make sure that the correct classes were applied to the correct links? When I left it, it should've been pretty much setup ;) Also, did you add the icons on in the order I mentioned in the e-mail? If not, the CSS won't correspond...

#30 vauxflow

vauxflow

    Advanced Member

  • Members
  • PipPipPip
  • 39 posts

Posted 17 February 2011 - 09:41 PM

Hi Kate, Yes I added the icons in the order you asked earlier and uploaded, once they uploaded everything was totally out of sync and looked worse than when I started so for the last few hours I??™ve been trying to sort it myself without much luck, might now use another template from another company I found online Kate because this stupid icon problem is getting out of control now, five days to add and arrange a few icons isn??™t good, would have hoped to have had this sorted now and moved on to other things especially as this site needs to be live in 2 days time. Simply just want a way to add icons, arrange them as I want them and add additional icons in the future if I need to without all this hassle everytime, surely there??™s a way to fix this or a simpler way of doing it.

#31 bryan-hadaway

bryan-hadaway

    Advocate

  • Members
  • PipPipPipPipPip
  • 3697 posts

Posted 18 February 2011 - 02:09 AM

Hi Craig,

Before we continue to help you with this you need to understand a few things;

- Please do not use profanity or rude language in the forum
- No matter what theme you use it is not going to have every bell and whistle you can think up, what you're asking for is a very specific customization to you that we are going above and beyond to assist you with
- This is the web design process, if you're attempting advanced customizations on your own and aren't comfortable with the learning curve and have a deadline, you may want to look into hiring a pro, we offer:

Please Login or Register to see this Hidden Content



So if you're ready to help us help you get this resolved we'd be happy to continue working with you.

Thanks, Bryan

#32 vauxflow

vauxflow

    Advanced Member

  • Members
  • PipPipPip
  • 39 posts

Posted 18 February 2011 - 12:06 PM

First of all Bryan, no-one used profanity or any other type of language, in fact I starred out a word!! As for the customisation, well no actually its not a bell or whistle type of specific customisation to me, I simply want to add a few icons and the correct URL's for those icons so its hardly a massive theme change or something no-one else has ever wanted to do, a simple fix, a let help is all I ask, all I have done is ask someone can they guide me in terms I understand after all I, like many others here paid a lot of money for this product and all I am asking for is a little product support, a product support document might have been a great idea to accompany the product! I actually take offence to your above post Bryan and I actually think it was not only uncalled for but not very resonable at all toward a customer. Also, no I dont want to pay out yet more money for a pro, I want some product help so you pushing yet another service to raise further revenue is quite wrong when a customer is asking for a little help with a tiny little fix and not a major custom job. At present I still do not have a fix for this, feel free to jump in at anytime and offer your help Bryan!

#33 Kate

Kate

    Advocate

  • Members
  • 3039 posts

Posted 18 February 2011 - 06:12 PM

Fixed ;)

#34 vauxflow

vauxflow

    Advanced Member

  • Members
  • PipPipPip
  • 39 posts

Posted 18 February 2011 - 07:48 PM

Thanks to this wonderful, patient and most helpful lady I have now got a solution and fix. This was a nightmare for me but an easy fix for someone who has extensive coding knowledge. After a certain unhelpful reply earlier I almost decided to ask to be refunded for this product, thankfully Kate came along and went out of her way to help with this and not once did she try to be-little someone that has fewer coding skills/knowledge than herself. Kate actually gave product support and remained very highly professional throughout. Great person who is a credit to Pagelines, just a pity certain other Pageline staff aren't as supportive as this lady! certain others would rather go out of their way to argue rather than help their customers. Very well done Kate, and again thank you so much for kindly helping with this matter. Your an angel.

#35 mikedmerrill

mikedmerrill

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 07 June 2011 - 01:32 PM

Hey all.

Wondering if you could help me.

I'm trying to add social media icons to the header by following the directions posted here. I don't need rollovers or the like.

Please Login or Register to see this Hidden Content



Here's the code I'm adding to functions.php

Please Login or Register to see this Hidden Content


However, it's not showing up. I get the feeling I'm missing something very simple.

Please help?

Thanks in advance!

M. Bos.