Archived

This topic is now archived and is closed to further replies.

  • 0

Highlight page graphic breaking

Question

Posted · Report post

Just now trying out highlight pages, they seem to be incomplete unless I enter text that goes all the way across the box. I've toggled plug-ins, I've removed post content. http://www.vineyardadventures.com/image_gallery/italy/ http://www.vineyardadventures.com/image_gallery/italy/central/toscana/ (plug in deactivated) Most of my highlight pages will be a single word header, which I would like centered. Then instructions on how to use the slide show as "highlight text" Discuss.

Share this post


Link to post
Share on other sites

20 answers to this question

Posted · Report post

Hey there Bilbomac, As I learned from another tweak: Appearance > Whitehouse Pro Options > Custom Code > Custom CSS

Share this post


Link to post
Share on other sites

Posted · Report post

To break out the other question, and to address something annoying: I would like for my Highlight title to be centered. Since the field is H1 preformatted, how do I go about doing that? It's also impossible to leave either field blank without getting the default text that says "fill me in on the admin page" Thanks!

Share this post


Link to post
Share on other sites

Posted · Report post

@Robbing_G Two lines of css in the custom css field should do it for you:

#highlight .fcontent {padding:50px 0;}
	#highlight h1 {text-align:center;}

Let me know if that works for you.

Share this post


Link to post
Share on other sites

Posted · Report post

ooo. my apologies! I forgot about the "highlight text". disregard that code above and use this instead:

#highlight h1 {text-align:center;}
It looks like you have this entered in the custom css field as well (delete this):
#maincontent #highlight .fcontent {width: 100%}

Now for the Default text issue, just add a space (" ")in the highlight text field. That should trick the the theme option into thinking you have text entered there.

Share this post


Link to post
Share on other sites

Posted · Report post

I can't delete #maincontent #highlight .fcontent {width: 100%} its Andrew's fix to the bug problem also listed in this thread... I delete that line and the problem comes back: http://www.vineyardadventures.com/image_gallery/italy/ I know the space is a cheat, but if the field were gone, the graphic would be narrower and that would be nice. (note for future updates)

Share this post


Link to post
Share on other sites

Posted · Report post

@Robbin_G Gotya! We're making slow progress, but progress nonetheless:

#maincontent #highlight .fcontent {width: 100%}
	#highlight h1 {text-align:center; margin-left:-50px}

That should do it for you. As for a resolution for the space cheat, I'm writing ticket for it right now.

Share this post


Link to post
Share on other sites

Posted · Report post

this is being caused by the: ` #maincontent #highlight .fcontent { width:100%; } ` custom css rule you added..

Share this post


Link to post
Share on other sites

Posted · Report post

@Robbin_G last attempt: #maincontent #highlight .fcontent {width: 540px} #highlight h1 {text-align:center} You can hate me forever if that doesn't work.

Share this post


Link to post
Share on other sites

Posted · Report post

Does this replace the previous code suggested above throughout the entire thread? So should the only entry in CSS code be... #maincontent #highlight .fcontent {width: 540px} #highlight h1 {text-align:center}

Share this post


Link to post
Share on other sites

Posted · Report post

@bilbomac Yes, the last bit of code replaces all previously mentioned code. (just as you copied)

Share this post


Link to post
Share on other sites

Posted · Report post

thx :-)

Share this post


Link to post
Share on other sites

Posted · Report post

Dumb question. Does it need to be placed inside brackets and associated with anything?

Share this post


Link to post
Share on other sites

Posted · Report post

Nope, just put in that custom css field.

Share this post


Link to post
Share on other sites

Posted · Report post

could you clarify what you mean by incomplete?

Share this post


Link to post
Share on other sites

Posted · Report post

The shaded area doesn't fill the box.

Share this post


Link to post
Share on other sites

Posted · Report post

argh.... ok you found a bug, congratulations.. :) to fix: `#maincontent #highlight .fcontent {width: 100%}`

Share this post


Link to post
Share on other sites

Posted · Report post

Which page/template would this code be added to?

Share this post


Link to post
Share on other sites