Archived

This topic is now archived and is closed to further replies.

  • 0

MAJOR WordPress Issue...

Question

Posted · Report post

So I am trying to log in to the WordPress control panel to edit my website and for some reason I am getting the following error: "Sorry, but you don??™t have the administrative privileges needed to do this." I don't know why this happened. I edited my website last night (just made some content changes) and today I went to go edit it and it is giving me this error message. I did upgrade the PHP from 4 to 5 today. I have no idea why it's doing this and really need my website up and running. Some detailed instructions would be great (I can't access WordPress at all). Thanks.

Share this post


Link to post
Share on other sites

8 answers to this question

Posted · Report post

You mean in the case you can't upgrade to PHP5?

Share this post


Link to post
Share on other sites

Posted · Report post

Hi, I am trying to migrate my site to its live domain from a dev domain. I have done a full DB backup and manually find/replaced all old domain references and replaced with new domain. I have done the same with all site files. However, when I try to access the site at its new location I get this error. "Sorry, but you don??™t have the administrative privileges needed to do this." I tried to use ?activated but it just messed up things even more, seeming to reset all WhiteHousePro data. This is really urgent. Please help.

Share this post


Link to post
Share on other sites

Posted · Report post

ohhh.. thats an interesting problem. I didn't realize you were on php4. This is a security measure to protect your site, to fix just add: `?activated=true` to the end of any site url...

Share this post


Link to post
Share on other sites

Posted · Report post

wow that worked...I went to wp-admin and added ?activated=true and it let me get in to my control panel and now the site is up again...so does this mean that I don't have to do anything else and it will be fine after this? sorry about all the questions, I am new to WordPress (much more familiar with HTML)... thanks

Share this post


Link to post
Share on other sites

Posted · Report post

Yes, ?activated=true solves the "Sorry, but you don't have the administrative privileges needed to do this." problem. I had also figured this out from the code. But this also resets the custom theme. So it is not really a solution. Is there a way to pass this and also keep the custom theme? (Running on lighttpd with php 5.1.6)

Share this post


Link to post
Share on other sites

Posted · Report post

yes you should be fine... its actually something with the theme that makes sure you are an administrator before you change options... since you were on php4 the options hadn't been set. it was a use case we didn't think of.

Share this post


Link to post
Share on other sites

Posted · Report post

Anyway to remove the code from the theme so I don't need to add the ?activated=true every time after an install?

Share this post


Link to post
Share on other sites