Archived

This topic is now archived and is closed to further replies.

  • 0

user does not exist after user integration config

Question

Posted · Report post

Hey folks - I'm in the process of setting up a brand new Wordpress/bbpress site. I've gotten a far piece down the road on integrating the forum with the blog, with the last remaining outstanding piece being user/cookie integration. After mapping roles across the sites (using the recommended settings) I put in the value for User integration (the table prefix for the WP database) and then saved the value. The screen refresh booted me out of the admin panel, and then when I tried to log into the BBPress site, my admin user login got a "user does not exist" response. So in essence I'm dead in the water. This isn't so bad - beyond the base annoyance. There's *nothing* on the site yet, so I'm not afraid to blow the forum away and start over again. However, if there's a way around that without "the nuclear option" I'd like to give it a try. And of course there's no guarantee that I *won't* hit the same issue again unless I understand the root cause of the issue, etc etc - so I don't want to blindly make a major move that would end up complicating things further. So - any advice on where the user integration settings are stored, and how to "reverse" it long enough to be able to separately log into the BBPress and WP admin consoles and troubleshoot? Thanks!

Share this post


Link to post
Share on other sites

6 answers to this question

Posted · Report post

No good. Cookies long since cleared (in fact I tried to log in on a completely new machine) to no avail. And I *would* log into bbPress and do something if my admin user actually worked. Duh. :) But I'll check the DB and see if I can revert the setting directly and have another bite at the apple. Thanks.

Share this post


Link to post
Share on other sites

Posted · Report post

when we were first getting used to bbPress we had a problem with the "Key Master" setting for the install. This is basically the user with all the privileges.. Its possible that you might not have that set correctly.. what did they say on the bbPress forum?

Share this post


Link to post
Share on other sites

Posted · Report post

I don't remember if I opened a thread on that forum, or if I was just searching for someone else dealing with the same issue. I'll make a sweep and check tomorrow morning early.

Share this post


Link to post
Share on other sites

Posted · Report post

Hey Houston, Are you still able to login into the WordPress Admin panel?

Share this post


Link to post
Share on other sites

Posted · Report post

Yes - I have full access to WP admin

Share this post


Link to post
Share on other sites

Posted · Report post

clear cookies, restart the browser. This is a common issue with bbP. All the integration info is stored in the bb-options table in the db. You can probably see it as well in the bbPress admin under 'WordPress Integration'

Share this post


Link to post
Share on other sites