Jump to content


Photo

Subnav problem


This topic has been archived. This means that you cannot reply to this topic.
6 replies to this topic

#1 jasonp

jasonp

    Advanced Member

  • Members
  • PipPipPip
  • 63 posts

Posted 10 January 2010 - 05:44 AM

Hi there! I have dropdowns enabled, and my main problem is that when you click on the heading itself it opens up the parent page...however the parent page doesn't show up on the Subnav that appears! It's very confusing from a design perspective...I've been getting around it by making dupclicates of that first page but need a more permanent solution. Thanks, Jason

#2 arpowers

arpowers

    Founder

  • Administrators
  • 3252 posts

Posted 10 January 2010 - 07:04 PM

you want the parent page to show up in the drop down?

#3 jasonp

jasonp

    Advanced Member

  • Members
  • PipPipPip
  • 63 posts

Posted 10 January 2010 - 11:06 PM

That would certainly be one easy way to solve it I think. I'm also looking into your other suggestion with: wp_list_pages('exclude='.$frontpage_id.$forum_exclude.'&depth=1&title_li=');?> Great stuff.

#4 arpowers

arpowers

    Founder

  • Administrators
  • 3252 posts

Posted 11 January 2010 - 08:15 PM

ya you can always tweak the code (wp_list_pages) you might also try the 'page links to' plugin to seamlessly redirect pages...

#5 jasonp

jasonp

    Advanced Member

  • Members
  • PipPipPip
  • 63 posts

Posted 13 January 2010 - 01:18 AM

Thanks Andrew. When you mean tweak code...is this something I can do in the custom code area? Or does it need to be done directly in the php files somewhere? I believe I know enough to be able to do the direct edits but I'm hoping to avoid things I can't update to the WHP database for easy upgrades. Thanks!

#6 jnoh

jnoh

    Advocate

  • Members
  • PipPipPipPipPip
  • 502 posts

Posted 13 January 2010 - 05:19 PM

You'll have to edit the 'header.php' theme file to do what you need, as there is no option for it in our themes. :/

Search for this code, you'll see it near the bottom of the file:

 wp_list_pages('exclude='.$frontpage_id.$forum_exclude.'&depth=1&title_li=');?>

delete '.$frontpage_id' an you should get the effect you're looking for.

#7 jasonp

jasonp

    Advanced Member

  • Members
  • PipPipPip
  • 63 posts

Posted 14 January 2010 - 07:09 AM

Thanks Andrew. On another string I actually was discussing how to simply enable the white mouseovers associated with the dropdown but without the actual dropdown. I'm still a bit confused on how to get this but for my purposes realized it's much preferable! It seems easier to lead a visitor where you want them to without them -- but the mouseovers make such a positive difference too.